Bug #88312

User group definitions not saved properly

Added by Robert Wildling over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
Backend User Interface
Target version:
-
Start date:
2019-05-09
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
user group, checkbox, Revert Selection
Complexity:
Is Regression:
Sprint Focus:

Description

When creating user groups, the "Files" and "Directory" settings under "Mounts and Workspaces" are not saved correctly, when no checkboxes are selected.
Also, "Revert Selection" does not do anything.

Steps to reproduce:
1. Create a user group
2. Under "Mounts and Workspaces" goto "Directory"
3. Click "Toggle all" twice, so no checkbox is selected
4. Save
--- List should be empty now
5. Check "Toggle all" under "Files" twice, so no checkbox is selected
6. Save

Result:
The checkboxes in "Directory" and "Files" have their initial configuration again.
This does not happen, when "Files" and "Directory" have at least on checkbox selected.

Further observations:
"Revert Selection" does not work (Andreas Fernandez confirmed on Slack, that it should work in current master, my tests are on 9.5.5)
The "Toggle All" functionality works as expected with all the "Modules" and "Tables (listing)" under "Access".

Tested on
TYPO3 8.7.24 "classic", php 7.2
TYPO3 9.5.5 "classic", php 7.2

Might be related to


Files

UserGroups.jpg (110 KB) UserGroups.jpg Robert Wildling, 2019-05-09 09:08

Related issues

Related to TYPO3 Core - Bug #88311: Access does not set all necessary rightsClosed2019-05-09

Actions
Related to TYPO3 Core - Bug #70812: edit user or usergroup > cannot remove every permission on file/directoriesAccepted2015-10-17

Actions
#1

Updated by Robert Wildling over 2 years ago

  • Related to Bug #88311: Access does not set all necessary rights added
#2

Updated by Riccardo De Contardi over 2 years ago

I think that this is the same issue: #70812

#3

Updated by Robert Wildling over 2 years ago

  • Related to Bug #70812: edit user or usergroup > cannot remove every permission on file/directories added
#4

Updated by Robert Wildling over 2 years ago

Thanks, Riccardo!
This issue could be closed in favor of #70812.

#5

Updated by Andreas Fernandez over 2 years ago

  • Status changed from New to Closed

Closed as duplicate of #70812

Also available in: Atom PDF