Bug #88513

Non-FQCN controllers should still be usable in Extbase

Added by Oliver Hader 3 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extbase
Start date:
2019-06-06
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

(1/1) #1316104317 TYPO3\CMS\Extbase\Mvc\Exception
The default controller for extension "News" and plugin "Pi1" can not be determined.
Please check for TYPO3\CMS\Extbase\Utility\ExtensionUtility::configurePlugin() in your ext_localconf.php.

configured as

    \TYPO3\CMS\Extbase\Utility\ExtensionUtility::configurePlugin(
        'GeorgRinger.News',
        'Pi1',
        [
            'News' => 'list,detail,selectedList,dateMenu,searchForm,searchResult',
            'Category' => 'list',
            'Tag' => 'list',
        ],
        [
            'News' => 'searchForm,searchResult',
        ]
    );

Which does not seem to be possible anymore since https://review.typo3.org/c/Packages/TYPO3.CMS/+/59566

Since the referenced issue is about "deprecation", it should provide a backward compatibility path without forcing users to upgrade. Otherwise it would be a "breaking" change.


Related issues

Related to TYPO3 Core - Task #87550: Use controller classes when registering plugins/modules Closed 2019-01-25

Associated revisions

Revision e87eb75a (diff)
Added by Alexander Schnitzler about 2 months ago

[BUGFIX] Convert class aliases of switchable controller actions to FQCN's

When the patch https://forge.typo3.org/issues/87550 changed the controller
configuration of plugins and modules to use fully qualified controller
class names instead of just controller aliases, the override mechanism
called switchable controller actions, that can be used via typoscript
and flexforms broke.

This is due to the fact that switchable controller actions are usually
still used with controller aliases rather than fully qualified controller
class names.

To fix this, method overrideSwitchableControllerActions of class
\TYPO3\CMS\Extbase\Configuration\AbstractConfigurationManager has been
adjusted to convert controller aliases to FQCN's before overriding the
controller configuration.

Releases: master
Resolves: #88513
Relates: #87550
Change-Id: Ie2d1eb4b64d03d4e17d08a85aa7f8e548bff92bb
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/60906
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Tested-by: Daniel Goerz <>
Reviewed-by: Benni Mack <>
Reviewed-by: Daniel Goerz <>

History

#1 Updated by Oliver Hader 3 months ago

  • Related to Task #87550: Use controller classes when registering plugins/modules added

#2 Updated by Oliver Hader 3 months ago

  • Description updated (diff)

#3 Updated by Oliver Hader 3 months ago

  • Description updated (diff)
  • Is Regression set to Yes

#4 Updated by Gerrit Code Review 3 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60906

#5 Updated by Gerrit Code Review 3 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60906

#6 Updated by Anonymous about 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Benni Mack about 1 month ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF