Bug #88928

routeEnhancers and GP conditions (TS) not working

Added by Henri Nathanson about 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
TypoScript
Target version:
-
Start date:
2019-08-07
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.3
Tags:
typoscript condition news GP routes routeEnhancer
Complexity:
Is Regression:
Sprint Focus:
On Location Sprint

Description

Old style GP typoscript conditions are not working with TYPO3v9.5.8

https://github.com/georgringer/news/issues/848

There has been some work on the matter lately, but I do not see, if it addresses the problem.
https://forge.typo3.org/issues/88252

Maybe low prio as we want to get to Symphony conditions anyway... but maybe awful to get stuck at this point.


Related issues

Related to TYPO3 Core - Bug #88252: Route Results are not available via TypoScript Closed 2019-04-30
Related to TYPO3 Core - Task #89176: Provide better way to traverse array in TS conditions Closed 2019-09-14

History

#1 Updated by Henri Nathanson about 1 year ago

  • Related to Bug #88252: Route Results are not available via TypoScript added

#2 Updated by Chris W about 1 year ago

How can i use TS like this while using routeEnhancers?

..
if.isTrue.data = GP:tx_news_pi1|news
..

#3 Updated by Henri Nathanson about 1 year ago

Chris W wrote:

How can i use TS like this while using routeEnhancers?

..
if.isTrue.data = GP:tx_news_pi1|news
..

Are you sure it is not working? The ticket is only about TS conditions.

#4 Updated by Markus Klein 9 months ago

  • Related to Task #89176: Provide better way to traverse array in TS conditions added

#5 Updated by Susanne Moog 9 months ago

  • Sprint Focus set to On Location Sprint

#6 Updated by Susanne Moog 9 months ago

  • Status changed from New to Needs Feedback

Please check if the documentation PR clears up the usage: https://github.com/TYPO3-Documentation/TYPO3CMS-Reference-Typoscript/pull/278

when using route enhancers, GET params are not available (as they aren't part of the URL anymore) - however with https://forge.typo3.org/issues/88252 access of the page arguments object is possible which can be used as an replacement.

#7 Updated by Georg Ringer 7 months ago

  • Status changed from Needs Feedback to Closed

closing the issue because solved

Also available in: Atom PDF