Bug #89063

Index too large for sys_redirect

Added by Ingo Fabbri about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-09-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

The following errors occurred:
+---------------+-------------------------------------------------+-----------------------------+
| Type          | SQL Statement                                   | Message                     |
+---------------+-------------------------------------------------+-----------------------------+
| Change fields | ALTER TABLE `sys_redirect` CHANGE `source_path` | Specified key was too long; |
|               | `source_path` VARCHAR(2048) DEFAULT '' NOT NULL | max key length is 3072      |
|               |                                                 | bytes                       |
|               |                                                 |                             |
+---------------+-------------------------------------------------+-----------------------------+

Reason: https://forge.typo3.org/issues/88336

affected database server version: mariadb-10.1.37


Related issues

Related to TYPO3 Core - Bug #88336: redirects: longer URL strings are stripped in source_pathClosed2019-05-12

Actions
Is duplicate of TYPO3 Core - Bug #89169: Redirects indey key too long after source path increaseClosed2019-09-13

Actions
#1

Updated by Ingo Fabbri about 2 years ago

  • Related to Bug #88336: redirects: longer URL strings are stripped in source_path added
#2

Updated by Marco Bresch about 2 years ago

Another affected database server is MySQL 5.7.23

#3

Updated by Ingo Fabbri about 2 years ago

updated from 9.5.8 to 9.5.9

#4

Updated by bitfire it services about 2 years ago

Can confirm this for Typo3 after upgrade from 9.5.8 to 9.5.9 with 5.7.27-0ubuntu0.18.04.1.

#5

Updated by Guido Schmechel about 2 years ago

  • Related to Bug #89169: Redirects indey key too long after source path increase added
#6

Updated by Frank Naegler about 2 years ago

  • Is duplicate of Bug #89169: Redirects indey key too long after source path increase added
#7

Updated by Frank Naegler about 2 years ago

  • Related to deleted (Bug #89169: Redirects indey key too long after source path increase)
#8

Updated by Manuel Selbach about 2 years ago

  • Status changed from New to Closed

See issue #89169

Also available in: Atom PDF