Bug #89342

InvalidArgumentException while parsing Services.yaml

Added by Sebastian Fischer almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Start date:
2019-10-03
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After installing current master i get the following exception

(1/2) Symfony\Component\DependencyInjection\Exception\InvalidArgumentException
The file "/home/www/dev10/www/public/typo3/sysext/core/Configuration//Services.yaml" does not contain valid YAML: Unexpected characters near " # Core caches, cache.core and cache.assets are injected as early # entries in TYPO3\CMS\Core\Core\Bootstrap and therefore omitted here" at line 40 (near "# entries in TYPO3\CMS\Core\Core\Bootstrap and therefore omitted here").

This is caused if both lines are present

  1. Core caches, cache.core and cache.assets are injected as early
  2. entries in TYPO3\CMS\Core\Core\Bootstrap and therefore omitted here

If I delete either one of them the parsing processes as expected. So i assume that the yaml parser does not like two comment lines after another.


Files

composer.json (1.02 KB) composer.json Sebastian Fischer, 2019-10-08 09:47
stacktrace.txt (24.6 KB) stacktrace.txt Sebastian Fischer, 2019-10-08 09:48
composer.json (248 Bytes) composer.json Richard Haeser, 2019-11-21 19:29
composer.lock (139 KB) composer.lock Richard Haeser, 2019-11-21 19:29
config.yaml (5.66 KB) config.yaml Richard Haeser, 2019-11-21 19:31
#1

Updated by Sebastian Fischer almost 2 years ago

The report is missing the path of the file /typo3/sysext/core/Configuration/Services.yaml

#2

Updated by Markus Klein almost 2 years ago

  • Description updated (diff)
#3

Updated by Frank Naegler almost 2 years ago

  • Status changed from New to Needs Feedback

I am not able to reproduce this issue. can you please add some more information about your system?

1) operating system?
2) PHP version?
3) composer mode or not?
4) a full stack trace would also be nice

#4

Updated by Sebastian Fischer almost 2 years ago

1) Ubuntu 18.04
2) PHP Version 7.2.22-1+ubuntu18.04.1+deb.sury.org+1
3) composer mode (composer.json attached)
4) stack trace is attached

#5

Updated by Frank Naegler almost 2 years ago

as mentioned in slack, please tell us also the symfony/yaml package version.

#6

Updated by Frank Naegler almost 2 years ago

  • Status changed from Needs Feedback to Closed

issue closed, the issue exists in a dev version of symfony/yaml package.
For now no issue, the author confirmed this.

#7

Updated by Richard Haeser almost 2 years ago

I have exactly the same issue when installing a fresh new install of TYPO3 v10.1

Symfony\Component\DependencyInjection\Exception\InvalidArgumentException
The file "/var/www/html/public/typo3/sysext/core/Configuration//Services.yaml" does not contain valid YAML: Unexpected characters near " # Core caches, cache.core and cache.assets are injected as early # entries in TYPO3\CMS\Core\Core\Bootstrap and therefore omitted here" at line 40 (near "# entries in TYPO3\CMS\Core\Core\Bootstrap and therefore omitted here").

Installation on ddev v1.11.2. See attached config

#8

Updated by Jan Greth almost 2 years ago

+1

I have the same Setup and Problem like Richard.

#9

Updated by Ralf Hübner almost 2 years ago

+1 Same issue.

Upgraded from 9.5.11 to 10.1

Symfony\Component\DependencyInjection\Exception\InvalidArgumentException
The file "D:/wamp64/www/typo3/v10/web/typo3/sysext/core/Configuration/\Services.yaml" does not contain valid YAML: Unexpected characters near " # Core caches, cache.core and cache.assets are injected as early # entries in TYPO3\CMS\Core\Core\Bootstrap and therefore omitted here" at line 40 (near "# entries in TYPO3\CMS\Core\Core\Bootstrap and therefore omitted here").

Set the two comments in one comment fixed the issue: # Core caches, cache.core and cache.assets are injected as early entries in TYPO3\CMS\Core\Core\Bootstrap and therefore omitted here

The Install-Tool is accessible, but nothing works:
Something went wrong

In Front-/Backend this error occurrs:
Fatal error: Class TYPO3\CMS\Core\Mail\FileSpool contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (Symfony\Component\Mailer\Transport\TransportInterface::__toString) in D:\wamp64\www\typo3\v10\web\typo3\sysext\core\Classes\Mail\FileSpool.php on line 38

#10

Updated by Benni Mack over 1 year ago

  • Status changed from New to Closed

Hey all,

we've fixed this with TYPO3 v10.2.

Also available in: Atom PDF