Bug #89369

Page translations faulty when editor has no permissions for "l10n_parent"

Added by Christian Eßl about 1 year ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
DataHandler aka TCEmain
Target version:
-
Start date:
2019-10-08
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

How to reproduce:
  • Create a site with the languages "Default" and "German"
  • Create a page "Test" as admin in the default language.
  • Create a backend user that is allowed to view and modify pages
  • Do not give the user access permissions to the field "l10n_parent"
  • Login as the backend user and try to translate the page

Expected result:
Page is translated

Actual Result:
  • A blank page is shown, the pagetree now infinitely shows the loading spinner
  • If you try to translate the same page again, an error message is shown:
    '"1: Localization failed: there already are localizations (5572) for language 20 of the "pages" record 885!"'

But the page translation is not visible in the list view. If you look into the db, the translation was inserted with the uid 5572, but l10n_parent is now 0, which should be the uid of the parent record.
This means, Datahandler is highly dependent on the backend users access permission to the l10n_parent field. If no permissions to this field exist, the newly created translation will be faulty.

I believe one of the following should happen to avoid this:
  1. Do not allow translating a page if the backend user has no permissions for the field l10n_parent
  2. Or make the Datahandler not care about the access permissions to l10n_parent when translating a page.

Related issues

Related to TYPO3 Core - Bug #89672: Missing l10n_parent field permission breaks page translation process Closed 2019-11-13

History

#1 Updated by Chris W 10 months ago

I can confirm this but in my case it is irrelevant if the editor has permissions for the field 'l10n_parent'.
Acutally editors in my TYPO3 9.5.11 projects are not able to create any translations at all.

Update
For me its wokring after i updated to TYPO3 9.5.13

#2 Updated by Oliver Krammer 9 months ago

I can confirm that Bug with Typo3 9.5.13 if the User don't have the permission l10n_parent at the Pages table.
I can't repair it as Admin, i have to delete it in the Database.

#3 Updated by Georg Ringer 8 months ago

  • Related to Bug #89672: Missing l10n_parent field permission breaks page translation process added

#4 Updated by Georg Ringer 8 months ago

  • Status changed from New to Closed

thanks for creating this issue!

this is a duplicate of #89672 and solved in 10. therefore this has been closed.

Also available in: Atom PDF