Bug #89444

TMENU - CUR not working with subpage and no translated page

Added by Thomas Scheibitz over 2 years ago. Updated 9 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
TypoScript
Target version:
-
Start date:
2019-10-18
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:
On Location Sprint

Description

If I create a multilingual page with a subpage and the subpage is not translated, I don't get the desired CUR in the translated page but CURIFSUB when I call it up.

Example:

Default
- Root
- Seite 1
- deutsch

English
- Root
- site 1
- deutsch (this page is not translated )

my config.yml:

rootPageId: 1
base: /
languages:
  - title: Deutsch
    enabled: true
    languageId: '0'
    base: /
    typo3Language: default
    locale: de_DE
    iso-639-1: de
    navigationTitle: Deutsch
    hreflang: de-DE
    direction: ''
    flag: de
  -
    title: English
    enabled: true
    languageId: 1
    base: /en/
    typo3Language: en
    locale: en_US.UTF-8
    iso-639-1: en
    navigationTitle: English
    hreflang: en-us
    direction: ltr
    flag: us
errorHandling: {  }
routes: {  }

my typoscript

lib.navigation.main = HMENU
lib.navigation.main {
    1 = TMENU
    1 {
        expAll = 1
        NO = 1
        NO {
            wrapItemAndSub = <li>|</li>
        }

        ACT < .NO

        CUR < .NO
        CUR {
            linkWrap = 111|222
        }

        CURIFSUB < .NO
        CURIFSUB {
            linkWrap = 333|444
        }

        IFSUB < .NO

        ACTIFSUB < .IFSUB
        wrap = <ul>|</ul>
    }

    2 < .1
}


Files

default.png (62.1 KB) default.png Thomas Scheibitz, 2019-10-18 10:00
backend_setup.png (244 KB) backend_setup.png Thomas Scheibitz, 2019-10-18 10:00
english.png (58.7 KB) english.png Thomas Scheibitz, 2019-10-18 10:00

Related issues

Related to TYPO3 Core - Bug #93839: "Hide page if no translation for current language exists" not honored for not translated subpagesClosed2021-03-31

Actions
#1

Updated by Thomas Scheibitz over 2 years ago

  • Description updated (diff)
#2

Updated by Thomas Scheibitz over 2 years ago

  • Description updated (diff)
#3

Updated by Susanne Moog about 2 years ago

  • Sprint Focus set to On Location Sprint
#4

Updated by Benni Mack 15 days ago

  • Related to Bug #93839: "Hide page if no translation for current language exists" not honored for not translated subpages added
#5

Updated by Benni Mack 15 days ago

  • Status changed from New to Needs Feedback

Hey Thomas,

I tried reproducing your issue with TYPO3 v11 and can't seem to reproduce this one, can you check with latest v10 / v11 again please?

Thank you!

#6

Updated by Thomas Scheibitz 9 days ago

  • Assignee set to Benni Mack
  • % Done changed from 0 to 100

Hey Benni,

this seems to be fixed in TYPO3 V11.

#7

Updated by Riccardo De Contardi 9 days ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Benni Mack)

@Thomas Scheibitz thank you for your reply;

I close this issue; if you think that this is the wrong decision or there is still work to be done here, please reopen it or ping me.

Thank you.

Also available in: Atom PDF