Bug #89530

Editors can't create bookmark in filelist

Added by Peter Kraume over 1 year ago. Updated 4 months ago.

Status:
Needs Feedback
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Start date:
2019-10-28
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

How to reproduce:
- create a backend user
- grant access to File>Filelist
- add File Mount
- then switch to the editor
- add a bookmark in the filelist
- confirm the "Create a bookmark" modal

Result:
- the create bookmark icon turns yellow, the bookmark menu icon in the top bar is animated but no new item is added to the bookmark menu
- furthermore it is not possible to hit the "create bookmark" button again to delete the bookmark

Adding a bookmark as an editor in the page or list module works fine as far as I've tested.

#1

Updated by Riccardo De Contardi over 1 year ago

  • Status changed from New to Needs Feedback

Can you test it again with 9.5.14? I was not able to reproduce it on 9.5.14 or 10.4.0-dev

#2

Updated by Peter Kraume about 1 year ago

I've tested again with four TYPO3 9.5.18 installations. Two still have the problem, two work fine.
I need to investigate more, if it is a rights issue or maybe a 3rd party module misbehaves or if it is something else. I'll keep you posted.

#3

Updated by Peter Kraume 9 months ago

This issue is still valid in TYPO3 9.5.21 and 10.4.8.
I've created fresh installations with DDEV and configured a user as described above.
Furthermore I've tested five TYPO3 9.5.21 production instances of our customers. In two of them editors could add bookmarks. In the other three, I have the same problem as described above.

During testing in my DDEV instances it suddenly worked after changing some user group settings. But I'm still not able to reproduce the solution reliably. I'll give it another try in the next days.

#4

Updated by Riccardo De Contardi 4 months ago

@Peter Kraume

Any news from this one?

Also available in: Atom PDF