Task #89566

Some buttons have missing tooltips

Added by Oliver Bartsch 20 days ago. Updated 20 days ago.

Status:
Under Review
Priority:
Should have
Category:
Backend User Interface
Target version:
-
Start date:
2019-11-01
Due date:
% Done:

0%

TYPO3 Version:
10
PHP Version:
Tags:
locallang, labels, tooltips
Complexity:
Sprint Focus:

Description

In various modules through the backend tooltips (a-Tag titles) are missing.

They either don't exist at all, reference to a locallang label which was removed sometime or reference to a locallang label in a different sysext which is no dependency of the one the label is accessed from.

E.g. in TYPO3\CMS\Backend\View\PageLayoutView:1784

$this->getLanguageService()->sL('LLL:EXT:frontend/Resources/Private/Language/locallang_webinfo.xlf:lang_renderl10n_viewPage') . '">' .

First of all, there is no such label lang_renderl10n_viewPage in this locallang file, moreover is ext:frontend no dependency of ext:backend and last but not least is the label not treated by htmlspecialchars

One more example: TYPO3\CMS\Backend\View\PageLayoutView:1789

htmlspecialchars($this->getLanguageService()->getLL('editThisPage')) . '">' .

Also this label does not exist.


Related issues

Related to TYPO3 Core - Bug #89520: Missing tooltips in info module New 2019-10-26

History

#1 Updated by Gerrit Code Review 20 days ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62175

#2 Updated by Gerrit Code Review 20 days ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62175

#3 Updated by Gerrit Code Review 20 days ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62175

#4 Updated by Tymoteusz Motylewski 19 days ago

  • Related to Bug #89520: Missing tooltips in info module added

Also available in: Atom PDF