Bug #89621

Move to clipboard button is missing in filelist module for editors

Added by Christian Buelter 7 months ago. Updated 5 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2019-11-08
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

The button which moves multiple selected files to the clipboard is missing in the file list module. Only editors are affected, admins still have this button.

Steps to reprdoduce
  1. Switch to an editor backend user.
  2. Go to the filelist module.
  3. Activate the "Show clipboard".
  4. Activate " Clipboard #1 (multi-selection mode)"

Multiple files can be selected but they cannot be transferred to the clipboard.

Please see screenshot.

This bug is new in TYPO3 9.5.10 and 9.5.11.
TYPO3 9.5.9 is not affected.

filelist-bug-typo3.png View (44.6 KB) Christian Buelter, 2019-11-08 17:10


Related issues

Related to TYPO3 Core - Bug #89669: Transfer to clipboard button missing in multi-selection mode Closed 2019-11-13
Related to TYPO3 Core - Bug #85425: Check the copy permissions correctly Closed 2018-06-28
Related to TYPO3 Core - Epic #90676: Clipboard related bugs and features Accepted 2020-03-07

History

#1 Updated by Christian Buelter 6 months ago

#2 Updated by Christian Buelter 6 months ago

  • Related to Bug #89669: Transfer to clipboard button missing in multi-selection mode added

#3 Updated by Christian Buelter 6 months ago

  • Related to Bug #85425: Check the copy permissions correctly added

#4 Updated by Christian Eßl 3 months ago

  • Related to Epic #90676: Clipboard related bugs and features added

#5 Updated by Riccardo De Contardi about 1 month ago

  • Status changed from New to Needs Feedback

I am not able to reproduce this issue on 9.5.15 or latest master (10.4.0-dev), using a non-admin BE user. I see the "copy to clipboard" icon and it works.

May I ask you to test it again or add more details about your configuration?

#6 Updated by Christian Buelter 12 days ago

I could not reproduce it in 9.5.15.

I downgraded my test environment to 9.5.11 to double-check. In my current test environment the bug does not appear (although my test environment differs from that which I used when I opened the bug, because some required packages have been updated since).

I updated to 9.5.17 and the bug does not appear.

I tested in a environment with 10.4.1 and 10.4.2 and the bug did not appear.

I think this can be closed.

#7 Updated by Riccardo De Contardi 5 days ago

  • Status changed from Needs Feedback to Closed

@Christian Buelter Thank you for your reply;

I close this issue in agreement witht the reporter; if you think that this is the wrong decision or experience the issue again, please reopen it or open a new issue with a reference to this one.

Thank you.

Also available in: Atom PDF