Bug #85425

Check the copy permissions correctly

Added by Guido Schmechel over 1 year ago. Updated about 1 month ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2018-06-28
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Given:
User with folder and file permissions. Just "read" and "add"

Problem:
Copy Icon is shown in context menu and button in file list.


Related issues

Related to TYPO3 Core - Bug #84554: User that has NO permission in group to delete files or folders in FAL can delete files and folders anyway Closed 2018-03-29
Related to TYPO3 Core - Bug #89669: Transfer to clipboard button missing in multi-selection mode Closed 2019-11-13
Related to TYPO3 Core - Bug #89621: Move to clipboard button is missing in filelist module for editors New 2019-11-08

Associated revisions

Revision 4c185299 (diff)
Added by Guido Schmechel 4 months ago

[BUGFIX] Check permissions on copy actions

No copy link in the context menu or the button
in the file list is displayed, when the user lacks the permission
to copy file or folder.

Resolves: #85425
Releases: master, 9.5
Change-Id: I442d17e04a87eb25a438c2c2e7f22aef70492061
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/57414
Tested-by: TYPO3com <>
Tested-by: Andreas Fernandez <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Anja Leichsenring <>

Revision c1fcffe3 (diff)
Added by Guido Schmechel 4 months ago

[BUGFIX] Check permissions on copy actions

No copy link in the context menu or the button
in the file list is displayed, when the user lacks the permission
to copy file or folder.

Resolves: #85425
Releases: master, 9.5
Change-Id: I442d17e04a87eb25a438c2c2e7f22aef70492061
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61813
Tested-by: TYPO3com <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Frank Nägler <>
Reviewed-by: Anja Leichsenring <>

Revision 9bc0fea3 (diff)
Added by Benjamin Franzke 4 months ago

[TASK] Fix CGL violation in FileList

https://review.typo3.org/c/Packages/TYPO3.CMS/+/57414 introduced
a CGL violation that was not discovered because the patchset was
pushed on 8th of august and was checked with php-cs-fixer 2.14.1
on bamboo where no violation was found.

In the meantime (between push and merge of the mentioned patch)
https://review.typo3.org/c/Packages/TYPO3.CMS/+/61564 has been
merged, which updates php-cs-fixer to 2.15.2 and contains new
rules.

Releases: master
Resolves: #89282
Related: #57414
Related: #85425
Change-Id: I61d5e6e5dc61b500fe620e59002f296f50f03214
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61835
Tested-by: TYPO3com <>
Tested-by: Björn Jacob <>
Tested-by: Oliver Bartsch <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Björn Jacob <>
Reviewed-by: Oliver Bartsch <>
Reviewed-by: Andreas Fernandez <>

History

#1 Updated by Guido Schmechel over 1 year ago

  • Assignee set to Guido Schmechel

#2 Updated by Guido Schmechel over 1 year ago

  • Related to Bug #84554: User that has NO permission in group to delete files or folders in FAL can delete files and folders anyway added

#3 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57414

#4 Updated by Gerrit Code Review over 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57414

#5 Updated by Gerrit Code Review about 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57414

#6 Updated by Gerrit Code Review 6 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/57414

#7 Updated by Gerrit Code Review 6 months ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/57414

#8 Updated by Gerrit Code Review 6 months ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/57414

#9 Updated by Gerrit Code Review 6 months ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/57414

#10 Updated by Gerrit Code Review 6 months ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/57414

#11 Updated by Gerrit Code Review 4 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61813

#12 Updated by Gerrit Code Review 4 months ago

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61813

#13 Updated by Guido Schmechel 4 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#14 Updated by Sebastian Müller 3 months ago

  • Related to Bug #89430: Copying directory in FileList throws exception added

#15 Updated by Sebastian Müller 3 months ago

  • Related to deleted (Bug #89430: Copying directory in FileList throws exception)

#16 Updated by Peter Kraume 2 months ago

  • Related to Bug #89669: Transfer to clipboard button missing in multi-selection mode added

#17 Updated by Christian Buelter 2 months ago

  • Related to Bug #89621: Move to clipboard button is missing in filelist module for editors added

#18 Updated by Benni Mack about 1 month ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF