Bug #89669

Transfer to clipboard button missing in multi-selection mode

Added by Peter Kraume 7 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2019-11-13
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

With #85425 there was a permission check introduced before showing the copy button in the file list module.

Now I have this problem: if an editor has the right to copy files but NOT the right to copy folders, the button "Transfer the selection of files to clipboard" is missing in clipboard 1, 2 and 3.
Thus the editor can't transfer a selection of files to the clipboard.

Copying/moving single files works fine.

See the two attached screenshots.

clipboard-normal.png View (91.5 KB) Peter Kraume, 2019-11-13 12:26

clipboard-1.png View (104 KB) Peter Kraume, 2019-11-13 12:26


Related issues

Related to TYPO3 Core - Bug #85425: Check the copy permissions correctly Closed 2018-06-28
Related to TYPO3 Core - Bug #89621: Move to clipboard button is missing in filelist module for editors Closed 2019-11-08

Associated revisions

Revision fef78597 (diff)
Added by Guido Schmechel 6 months ago

[BUGFIX] Revert FolderCheck for clipboard actions

Due to a faulty query in #85425 it was no longer possible
to copy files at the clipboard multi-selection-mode.

This must be possible if the user has the permission to copy files,
but not to copy folders.

Resolves: #89669
Releases: master, 9.5
Change-Id: I1c26696a6c3886dd5669957cdce8ca472b17b577
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62321
Tested-by: Peter Kraume <>
Tested-by: TYPO3com <>
Tested-by: Henrik Elsner <>
Tested-by: Benni Mack <>
Reviewed-by: Peter Kraume <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Henrik Elsner <>
Reviewed-by: Markus Klein <>
Reviewed-by: Benni Mack <>

Revision ccd86d4d (diff)
Added by Guido Schmechel 6 months ago

[BUGFIX] Revert FolderCheck for clipboard actions

Due to a faulty query in #85425 it was no longer possible
to copy files at the clipboard multi-selection-mode.

This must be possible if the user has the permission to copy files,
but not to copy folders.

Resolves: #89669
Releases: master, 9.5
Change-Id: I1c26696a6c3886dd5669957cdce8ca472b17b577
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62657
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Reviewed-by: Benni Mack <>

History

#1 Updated by Peter Kraume 7 months ago

  • Related to Bug #85425: Check the copy permissions correctly added

#2 Updated by Gerrit Code Review 7 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62321

#3 Updated by Christian Buelter 7 months ago

  • Related to Bug #89621: Move to clipboard button is missing in filelist module for editors added

#4 Updated by Gerrit Code Review 6 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62657

#5 Updated by Gerrit Code Review 6 months ago

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62657

#6 Updated by Guido Schmechel 6 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Benni Mack 6 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF