Bug #89904

Potential problems with guzzlehttp/guzzle:6.5.0 due to INTL_IDNA_VARIANT_UTS46

Added by Oliver Hader 6 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
composer
Target version:
-
Start date:
2019-12-10
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

GuzzleHttp\Exception\InvalidArgumentException
IDN conversion failed in vendor/guzzlehttp/guzzle/src/Client.php line 241

→ see https://github.com/guzzle/guzzle/issues/2448
→ similar to #87953 - which has been fixed internally

We might consider defining guzzlehttp/guzzle:6.5.0 in conflict section of our composer.json in typo3/cms-core


Related issues

Related to TYPO3 Core - Task #90634: Allow latest guzzle versions Closed 2020-03-04
Related to TYPO3 Core - Bug #90940: IDN conversion failed | GuzzleHttp Closed 2020-04-03

Associated revisions

Revision 59d5159a (diff)
Added by Benni Mack 6 months ago

[BUGFIX] Mark guzzlehttp/guzzle >= 6.5.0 as conflict

Due to the INTL/ICU bug, which we
have seen on various places, Guzzle, which
does not cover our edge cases yet, ran
in the same issue as our Core versions earlier
in 2019.

See
https://github.com/guzzle/guzzle/issues/2448
https://github.com/guzzle/guzzle/pull/2454

For the time being, lets mark guzzle as
incompatible until Guzzle has solved the issue
and released a new version, so we can loosen
the conflict constraint.

Related: #87953
Resolves: #89904
Releases: master, 9.5, 8.7
Change-Id: If64fb9472d046f020c850cd0551beeaf78796b60
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62606
Tested-by: TYPO3com <>
Tested-by: Oliver Hader <>
Reviewed-by: Oliver Hader <>

Revision 4a8e8001 (diff)
Added by Benni Mack 6 months ago

[BUGFIX] Mark guzzlehttp/guzzle >= 6.5.0 as conflict

Due to the INTL/ICU bug, which we
have seen on various places, Guzzle, which
does not cover our edge cases yet, ran
in the same issue as our Core versions earlier
in 2019.

See
https://github.com/guzzle/guzzle/issues/2448
https://github.com/guzzle/guzzle/pull/2454

For the time being, lets mark guzzle as
incompatible until Guzzle has solved the issue
and released a new version, so we can loosen
the conflict constraint.

Related: #87953
Resolves: #89904
Releases: master, 9.5, 8.7
Change-Id: If64fb9472d046f020c850cd0551beeaf78796b60
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62612
Tested-by: TYPO3com <>
Tested-by: Oliver Hader <>
Reviewed-by: Oliver Hader <>

Revision bb11a3e0 (diff)
Added by Benni Mack 6 months ago

[BUGFIX] Mark guzzlehttp/guzzle >= 6.5.0 as conflict

Due to the INTL/ICU bug, which we
have seen on various places, Guzzle, which
does not cover our edge cases yet, ran
in the same issue as our Core versions earlier
in 2019.

See
https://github.com/guzzle/guzzle/issues/2448
https://github.com/guzzle/guzzle/pull/2454

For the time being, lets mark guzzle as
incompatible until Guzzle has solved the issue
and released a new version, so we can loosen
the conflict constraint.

Related: #87953
Resolves: #89904
Releases: master, 9.5, 8.7
Change-Id: If64fb9472d046f020c850cd0551beeaf78796b60
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62613
Tested-by: TYPO3com <>
Tested-by: Oliver Hader <>
Reviewed-by: Oliver Hader <>

History

#1 Updated by Gerrit Code Review 6 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62606

#2 Updated by Gerrit Code Review 6 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62606

#3 Updated by Gerrit Code Review 6 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62612

#4 Updated by Gerrit Code Review 6 months ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62613

#5 Updated by Benni Mack 6 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Benni Mack 5 months ago

  • Status changed from Resolved to Closed

#7 Updated by Markus Klein 2 months ago

  • Related to Task #90634: Allow latest guzzle versions added

#8 Updated by Oliver Hader 2 months ago

  • Related to Bug #90940: IDN conversion failed | GuzzleHttp added

Also available in: Atom PDF