Project

General

Profile

Actions

Bug #90940

closed

IDN conversion failed | GuzzleHttp

Added by Attila Glück almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
composer
Target version:
Start date:
2020-04-03
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

After update to 9.5.15 i see many of this errors:
Core: Exception handler (WEB): Uncaught TYPO3 Exception: IDN conversion failed | GuzzleHttp\Exception\InvalidArgumentException thrown in file /html/typo3/vendor/guzzlehttp/guzzle/src/functions.php in line 384.

Hosted by Mittwald


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Task #90634: Allow latest guzzle versionsClosedBenni Mack2020-03-04

Actions
Related to TYPO3 Core - Bug #89904: Potential problems with guzzlehttp/guzzle:6.5.0 due to INTL_IDNA_VARIANT_UTS46Closed2019-12-10

Actions
Actions #1

Updated by Attila Glück almost 4 years ago

An other Info to this issue: The requested urls whitch caused this errors, are not available Sites (404)

Actions #2

Updated by Attila Glück almost 4 years ago

  • Related to Task #90634: Allow latest guzzle versions added
Actions #3

Updated by Oliver Hader almost 4 years ago

  • Related to Bug #89904: Potential problems with guzzlehttp/guzzle:6.5.0 due to INTL_IDNA_VARIANT_UTS46 added
Actions #4

Updated by Oliver Hader almost 4 years ago

Can you please check which "ICU" (e.g. phpinfo()) version is used on that Mittwald system?
Basically it's the same behavior as in https://github.com/guzzle/guzzle/issues/2448 which obviously was not correctly fixed in GuzzleHttp in last to versions (6.5.1, 6.5.2)

Actions #5

Updated by Attila Glück almost 4 years ago

ICU version 4.4.1
ICU Data version 4.4.0.1
ICU TZData version 2010i
ICU Unicode version 5.2

Actions #6

Updated by Riccardo De Contardi almost 4 years ago

  • Category set to composer
Actions #7

Updated by Kim Christiansen almost 4 years ago

I had the same error on a Mittwald server.
Downgrade on TYPO3 9.5.14 solved the problem.

Actions #8

Updated by Dennis Prinse almost 4 years ago

With the latest release of the guzzlehttp/guzzle package (v6.5.3) the problems have been resolved with our environments for what I can see now.
I think this commit (https://github.com/guzzle/guzzle/pull/2550) resolved the issue and I hope it resolves your issues too.

Actions #9

Updated by Attila Glück almost 4 years ago

Unfortunately does not, if i try an url in frontend which does not exist i see always this error in backend log

Actions #10

Updated by Benni Mack almost 4 years ago

  • Is Regression set to Yes
Actions #11

Updated by Benni Mack almost 4 years ago

  • Target version set to next-patchlevel
Actions #12

Updated by Benni Mack almost 4 years ago

  • Status changed from New to Needs Feedback

Please ensure that this option is set in your LocalConfiguration.php

'HTTP' => [
'idn_conversion' => false
],

This option is safe to set in any installation where you don't have umlaut domains in your site configuration.

Actions #13

Updated by Attila Glück almost 4 years ago

It works! Thank you Benni!

Actions #14

Updated by Benni Mack almost 4 years ago

  • Status changed from Needs Feedback to Closed
Actions

Also available in: Atom PDF