Bug #90159

Site config: language baseVariants get removed when saving from GUI

Added by Jonas Eberle almost 2 years ago. Updated 8 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2020-01-20
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

baseVariants for languages (https://docs.typo3.org/m/typo3/reference-coreapi/master/en-us/ApiOverview/SiteHandling/AddLanguages.html#base) can currently only be edited by editing the site config .yaml directly. (Which is not the focus of this issue, but does anybody know if there is an feature request for this already?)

But if a site contains language baseVariants they will be removed from the .yaml after saving the site config in the backend.

languages:
 -
    languageId: '2'
    base: 'https://domain.ch/'
    baseVariants:
      -
        base: 'http://ch.stagingdomain.de/'
        condition: 'applicationContext matches "#^.*/Staging#"'
      -
        base: 'https://domain.ch.test/'
        condition: 'applicationContext matches "#^.*/Local$#"'

This could be solved by adding the missing configuration fields to the GUI (see above, maybe there is a feature request already for that?).


Related issues

Related to TYPO3 Core - Bug #93719: Site config: language baseVariants still get removed when saving from GUINew2021-03-12

Actions
Is duplicate of TYPO3 Core - Bug #89116: Selective writing of site config broken for nested structuresClosed2019-09-09

Actions
#1

Updated by Jonas Eberle over 1 year ago

  • Category changed from Backend User Interface to Link Handling, Site Handling & Routing
#3

Updated by Georg Ringer over 1 year ago

  • Status changed from New to Accepted
  • Priority changed from Should have to Must have
#4

Updated by Jonas Eberle over 1 year ago

  • Is duplicate of Bug #89116: Selective writing of site config broken for nested structures added
#5

Updated by Jonas Eberle over 1 year ago

  • % Done changed from 0 to 100

This can be closed as it was fixed in 9 and 10: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61603

#6

Updated by Benni Mack over 1 year ago

  • Status changed from Accepted to Closed
#7

Updated by Ben Robinson 8 months ago

Under TYPO3 10.4.13 this does not work properly yet. I have manually entered a baseVariant for a language in the yaml file and then changed the title of the language via the GUI. The baseVariant got lost in the process.

#8

Updated by Jonas Eberle 8 months ago

@Ben could you open a new issue with steps to reproduce please?

#9

Updated by Ben Robinson 8 months ago

  • Related to Bug #93719: Site config: language baseVariants still get removed when saving from GUI added

Also available in: Atom PDF