Project

General

Profile

Actions

Bug #90257

closed

[xxx in tree.rootLineIds] TypoScript condition causes page cache regeneration on each request

Added by Wiebke Lauke over 4 years ago. Updated 5 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Caching
Target version:
-
Start date:
2020-01-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
12
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

For example condition:

[123 in tree.rootLineIds]
# add a class to body tag
[GLOBAL]

That condition works fine in Application Context "Development" (no cache) but doesn't work in Application Context "Production" (caching).

See also https://forge.typo3.org/issues/88374

That bug still exists in TYPO3 9.5.13.


Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Bug #88374: [xxx in tree.rootLineIds] TypoScript condition causes page cache regeneration on each requestClosed2019-05-16

Actions
Related to TYPO3 Core - Feature #97816: New TypoScript parserClosed2022-06-27

Actions
Related to TYPO3 Core - Bug #102531: Wrong visitor in FE condition matchingResolved2023-11-27

Actions
Actions #1

Updated by Christian Eßl over 4 years ago

  • Category set to Caching
Actions #2

Updated by Benni Mack over 1 year ago

  • Related to Bug #88374: [xxx in tree.rootLineIds] TypoScript condition causes page cache regeneration on each request added
Actions #3

Updated by Christian Kuhn over 1 year ago

  • Status changed from New to Needs Feedback

Hey.

I think this resolved meanwhile, at least in v12: condition verdicts are part of the page cache identifier hash, if their verdict changes, which can't happen for a rootline condition for the same page, different page cache entries are generated.

Would you like to recheck? From what I remember of the <v12 code, it should do as well, and in v12 these areas have been streamline systematically so I'm rather sure it's fine in v12.

Actions #4

Updated by Christian Kuhn about 1 year ago

  • Status changed from Needs Feedback to Closed
Actions #5

Updated by Johannes Rebhan 9 months ago

  • TYPO3 Version changed from 9 to 12

The pages are cached, the result though is that the condition is not changing the values as expected. Example:

logo = EXT:koch_theme/Resources/Public/Images/logo.svg
[45 in tree.rootLineIds]
logo = EXT:koch_theme/Resources/Public/Images/logo-snowboard.svg
[END]

Now if I visit a page below the 45 PID and a cache entry is generated, the logo will be shown across the whole page, even outside the 45 pid rootline. Then If I recreate the cache entry outside the 45 pid rootline, it will show the logo.svg even on all pages inside the 45 pid rootline.

Actions #6

Updated by Christian Kuhn 9 months ago

Actions #7

Updated by Christian Kuhn 9 months ago

  • Status changed from Closed to New

reopened. needs reproduce confirmation.

Actions #8

Updated by Christian Kuhn 7 months ago

Maybe this is fixed with https://forge.typo3.org/issues/102531 ?

Actions #9

Updated by Christian Kuhn 7 months ago

  • Status changed from New to Needs Feedback
Actions #10

Updated by Christian Kuhn 7 months ago

  • Related to Bug #102531: Wrong visitor in FE condition matching added
Actions #11

Updated by Christian Kuhn 5 months ago · Edited

  • Status changed from Needs Feedback to Closed

Hey.

I re-tested this in FE with this TS:

page = PAGE
page.10 = TEXT
page.10.value = foo
[33346 in tree.rootLineIds]
page.10.value = bar
[END]

Works for me, I was unable to reproduce an issue together with cached / non cached pages and different pages where the condition matches or does not.

Since we fixed a condition related issue in v12 with #102531 and I think another one before of that, I'm kinda sure there is currently no further issue with that.

I hope its ok to close here for now since there was also no more feedback on the topic.

Actions

Also available in: Atom PDF