Feature #90325

Folder path should change in a file collection when renaming the folder

Added by Tim Jonas Pflaum over 1 year ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2020-02-05
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
Complexity:
medium
Sprint Focus:

Description

Prerequisits:
Typo3 v8.7.30 (most likely also in v9)

Steps to reproduce:
1. Create folder in filelist
2. Create a file collection of type: folder from storage
2.1 Select a folder
3. Rename the folder used in the file collection in the filelist

Expected behavior:
Folder is renamed in the file collection

Actual behavior:
Folder still has the old file path in the file collection which isn’t valid anymore so it shows: Invalid value

Additional notes:
Possible solution might be to implement something similar to the FileReference -> FolderReference and have the filecollection use database entries
Also when renaming a folder in the filelist the paths for subfolders have to be adjusted

Other possibility would be to check filecollections for references to the folder or subfolder and update it


Related issues

Related to TYPO3 Core - Feature #78036: Renaming of a folder in the filelist should adjust filemounts accordinglyClosed2016-09-22

Actions
#1

Updated by Georg Ringer over 1 year ago

  • Related to Feature #78036: Renaming of a folder in the filelist should adjust filemounts accordingly added
#2

Updated by Georg Ringer over 1 year ago

closed as duplicate of #78036

#3

Updated by Oliver Bartsch 8 months ago

  • Status changed from New to Closed

Hi, as Georg already mentioned this is a duplicate of #78036, which was already merged in the meantime (See: https://review.typo3.org/c/Packages/TYPO3.CMS/+/67441).

Therefore, I'll close this issue now. If you think there is still something not working correct, please contact me so I can reopen this issue or directly create a new one.

Also available in: Atom PDF