Bug #90335

Login Failure Warning email doesn’t show IP addresses

Added by RVVN no-lastname-given over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2020-02-06
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since TYPO3 9.5 the login failure warning email doesn’t contains IP addresses anymore. Instead there is a marker ###IP###.

This is a dump of the failures:

05-02-20 17:52:  Login-attempt from ###IP###, username 'johndoe' not found!!
05-02-20 18:01:  Login-attempt from ###IP###, username 'janedoe', password not accepted!
05-02-20 18:01:  Login-attempt from ###IP###, username 'janedoe', password not accepted!
05-02-20 18:02:  Login-attempt from ###IP###, username 'johndoe' not found!!

Is it some kind of anonymization ?

I checked the function BackendUserAuthentication::checkLogFailures() and it uses the raw log_data from sys_log without replacing this marker.

Also available in: Atom PDF