Bug #90614

TYPO3 scheduler floods sys_log with "Task is already running and multiple executions are not allowed, skipping!"

Added by Sybille Peters 3 months ago. Updated 3 months ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
scheduler
Target version:
-
Start date:
2020-03-02
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
scheduler
Complexity:
Is Regression:
Sprint Focus:

Description

I am not sure if this is the exact same problem as https://forge.typo3.org/issues/25615 (which has been closed), but it looks like it.

How problem manifests itself

  • Multiple scheduler PHP processes running
  • sys_log is flooded with massive amount of messages, all about the same time

[scheduler]: scheduler - Task is already running and multiple executions are not allowed, skipping! Class: TYPO3\CMS\Scheduler\Task\CachingFrameworkGarbageCollectionTask, UID: 8

  • Scheduled tasks in BE shows: "Caching framework garbage collection (scheduler)" as still running

Reason for problem

Probably a chain of several errors. In any case, it would be greate if sys_log would not get flooded (and allocate more than 50GB thus causing problems on weekend and affect stability of other TYPO3 systems on same DB server)

System

TYPO3 version: 8.7.30.

(I realize this is not the latest, will update to 8.7.31 shortly, but it looks like no change was made in this area.)


Related issues

Related to TYPO3 Core - Bug #25615: Scheduler floods sys_log in endless loop if a task is running and multiple executions isn't allowed Closed 2009-09-26

History

#1 Updated by Sybille Peters 3 months ago

  • Related to Bug #25615: Scheduler floods sys_log in endless loop if a task is running and multiple executions isn't allowed added

#2 Updated by Susanne Moog 3 months ago

  • Status changed from New to Rejected

This most likely won't be fixed for version 8 anymore, it has been fixed for 9 and 10 since 2 years ago with #83866 - if you need that in 8, use for example composer-patches to backport the patch in your instance.

Also available in: Atom PDF