Bug #90827

If you edit the page content element, the "Last Mod." does not change.

Added by Edward A. Gabdullin 7 months ago. Updated 3 months ago.

Status:
Needs Feedback
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2020-03-25
Due date:
% Done:

0%

TYPO3 Version:
10
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Good afternoon!
If you edit the page properties, then in the sitemap.xml the "Last Mod." changes. If you edit the page content element, the "Last Mod." does not change.

History

#1 Updated by Georg Ringer 7 months ago

  • Status changed from New to Needs Feedback

The field SYS_LASTCHANGED is only updated in the frontend once the page has been rendered. Can you confirm that this is working then for you?

What I did:
  1. Check lastmod in sitemap
  2. Edit content element on page
  3. Call page in frontend
  4. Check sitemap again

#2 Updated by Edward A. Gabdullin 7 months ago

What I did:
  1. Check lastmod in sitemap
  2. Edit content element on page
  3. Call page in frontend
  4. Check sitemap again

Repeated several times according to your instructions. "Last.Mod" does not change.

#3 Updated by Riccardo De Contardi 3 months ago

I think I can confirm this issue with the latest master

My test procedure

1) configure the xml sitemap (just the plain one as described here: https://docs.typo3.org/c/typo3/cms-core/master/en-us/Changelog/9.4/Feature-84525-XMLSitemap.html

2) access the map using a separate browser window (I used incognito mode)

3) check for a page in the map, for example:

URL Last Mod. Change freq. Priority
https://typo3.master.it:8890/one-page 2019-03-25 22:10 +01:00 0.5

4) go to the backend on the page
5) change a content element on the page, save

6) refresh the sitemap

Result:

the Last Mod. value does not change

- I even tried to flush the caches
- I even tried to set:

seo_sitemap.config.cache_period = 1

Is there something I am missing?

Also available in: Atom PDF