Bug #91025

List of changes in workspace view stays empty in BE

Added by Max Kugler over 1 year ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2020-04-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After successfully publishing changes to the text body of a content element (see attachment Step 2), I tried to visit the list of changes in workspace view in BE in order to publish further changes (see attachment Step 3). Unfortunately the list stays empty. Inspecting the loading process with the developer tools of the browser shows, that there is a certain XHTML request failing (see attachement step 3a). Moreover there is an exception logged in the BE everytime one tries to view the list of changes (see attachment step 3c).

After inspecting the piece of code that throws the exception, I found some comments there, mentioning the reference index. So i tried updating the reference in BE (see attachment 4a) and suddenly the exception went away (see attachement 4c). So obviously there was still a reference to the published content element in the index table (see attachment 3b and 4b), that was causing the exception. Is this normal behaviour, the result of a wrong configuration of the workspaces or simply a bug in typo3 in workspace handling???


Files

Step 1a - Make minor change to content element in draft workspace VHS.png (54 KB) Step 1a - Make minor change to content element in draft workspace VHS.png Max Kugler, 2020-04-14 14:30
Step 1b - New content element in database.png (18.1 KB) Step 1b - New content element in database.png Max Kugler, 2020-04-14 14:30
Step 2a - Publishing change to LIVE.png (32.3 KB) Step 2a - Publishing change to LIVE.png Max Kugler, 2020-04-14 14:30
Step 2b - Log entries created during publishing.png (94.5 KB) Step 2b - Log entries created during publishing.png Max Kugler, 2020-04-14 14:30
Step 3a - List further changes in workspace view in BE.png (223 KB) Step 3a - List further changes in workspace view in BE.png Max Kugler, 2020-04-14 14:30
Step 3b - State of tt_content and sys_refindex after publishing.png (20.7 KB) Step 3b - State of tt_content and sys_refindex after publishing.png Max Kugler, 2020-04-14 14:30
Step 3c - Error log in BE.png (26.7 KB) Step 3c - Error log in BE.png Max Kugler, 2020-04-14 14:30
Step 4a - Fixing it by updating the reference index.png (29.1 KB) Step 4a - Fixing it by updating the reference index.png Max Kugler, 2020-04-14 14:30
Step 4b - State of sys_refindex after updating the reference index.png (5.39 KB) Step 4b - State of sys_refindex after updating the reference index.png Max Kugler, 2020-04-14 14:30
Step 4c - No more exception in BE after updating the refindex.png (224 KB) Step 4c - No more exception in BE after updating the refindex.png Max Kugler, 2020-04-14 14:30

Related issues

Related to TYPO3 Core - Bug #85780: Published change is not visible anymore in BE workspace view but in workspace previewClosed2018-08-08

Actions
Related to TYPO3 Core - Bug #67676: Element "sys_file_reference:XXX" does not exist"ClosedOliver Hader2015-06-22

Actions
Related to TYPO3 Core - Bug #90073: Change sorting of records in list module / draft workspaces breaks workspace moduleNew2020-01-09

Actions
#1

Updated by Max Kugler over 1 year ago

  • Related to Bug #85780: Published change is not visible anymore in BE workspace view but in workspace preview added
#2

Updated by Dave Zen over 1 year ago

I had the same error message with a mask element

Core: Exception handler (WEB): Uncaught TYPO3 Exception: #1393960943: Element "tx_mask_slide:441" does not exist | RuntimeException thrown in file /var/www/typo3/web/typo3/sysext/workspaces/Classes/Dependency/ElementEntityProcessor.php in line 187. Requested URL: https://domain.de/typo3/index.php?route=%%2Fajax%%2Fworkspace%%2Fdispatch&token=--AnonymizedToken--

..whenever I visited a recently edited page in workspace mode. I checked in the database and there was no slide with this id.

I don't know what the editor changed and by the time the new content elements should get the approval they were not visible in the workspace modul.

I updated the reference index and now the content elements are shown again in the workspace module.

Not sure if that is reletaed to this issue: https://forge.typo3.org/issues/67676 ?

#3

Updated by Riccardo De Contardi over 1 year ago

  • Related to Bug #67676: Element "sys_file_reference:XXX" does not exist" added
#4

Updated by Riccardo De Contardi over 1 year ago

#67676 looks like the same issue

#5

Updated by Benni Mack about 1 year ago

  • Related to Bug #90073: Change sorting of records in list module / draft workspaces breaks workspace module added
#6

Updated by Christian Kuhn 12 months ago

  • Status changed from New to Closed

Hey. Thanks for the analysis and the screenis. I looked through the issue and I'm pretty certain it has been fixed with the refindex patches we've done lately.

The error handling of the workspace module isn't that great at the moment: If the ajax call fatal, there is no good response. A server side fatal can have various causes, the broken refindex cases should have been sorted out by now, though.

I'll close the issue for now. An existing instance can be fixed by calling the refindex:update cli.

Please create new issues if you still run into workspace ajax fatals, they may have different causes and need a dedicated look then.

Also available in: Atom PDF