Project

General

Profile

Actions

Bug #91045

closed

Language overlay does not respect $disableGroupAccessCheck

Added by Remo H. about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Localization
Target version:
-
Start date:
2020-04-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When calling getPage on PageRepository with $disableGroupAccessCheck = true, this argument has no effect for language overlays.

Restrictions in Method getPageOverlaysForLanguageUids are hardcoded to frontend context:

$queryBuilder->setRestrictions(GeneralUtility::makeInstance(FrontendRestrictionContainer::class));

This is an issue when generating links, through Solr indexing service. As an example, links to a user (fe_user records) profile page which has an frontend access group.
Generated links will always use the default language slug which leads to invalid links.

Solution: remove group check from restrictions when getPage is called with $disableGroupAccessCheck = true


Related issues 2 (0 open2 closed)

Has duplicate TYPO3 Core - Bug #90842: FE user restriction on pages and link incl. linkAccessRestrictedPages create wrong URLsClosed2020-03-26

Actions
Is duplicate of TYPO3 Core - Bug #87969: Page route for translated page is not generated correctly when page has frontend group access restrictionsClosed2019-03-20

Actions
Actions #1

Updated by Christian Eßl about 4 years ago

  • Has duplicate Bug #90842: FE user restriction on pages and link incl. linkAccessRestrictedPages create wrong URLs added
Actions #2

Updated by Christian Eßl about 4 years ago

  • Is duplicate of Bug #87969: Page route for translated page is not generated correctly when page has frontend group access restrictions added
Actions #3

Updated by Christian Eßl about 4 years ago

Hi, can you test this patch:
https://review.typo3.org/c/Packages/TYPO3.CMS/+/63963

This should fix the problem.

Actions #4

Updated by Benni Mack about 4 years ago

  • Status changed from New to Resolved
Actions #5

Updated by Benni Mack about 4 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF