Bug #87969

Page route for translated page is not generated correctly when page has frontend group access restrictions

Added by Helmut Hummel almost 2 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2019-03-20
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The URI Builder fetches the slug field of the target page to generate the URI.
This works also for pages with frontend group access restrictions, because PageRepository::getPage is called with disableGroupCheck.

However when a translated page should be fetched, the disableGroupCheck argument is not pushed through the query which fetches the translation,
which leads to the situation that the translation is not found and the slug of the default language page is used. In the end this leads to a wrongly composed URL.

To reproduce:

  1. Create a page
  2. Translate the page to another language
  3. Add frontend group access restriction to page in default language
  4. Preview translated page (preview button of translated page)

Related issues

Related to TYPO3 Core - Bug #86653: Preview of page, with "show", not working when starttime is setClosed2018-10-14

Actions
Related to TYPO3 Core - Bug #90842: FE user restriction on pages and link incl. linkAccessRestrictedPages create wrong URLsClosed2020-03-26

Actions
Has duplicate TYPO3 Core - Bug #91045: Language overlay does not respect $disableGroupAccessCheckClosed2020-04-15

Actions
#1

Updated by Georg Ringer almost 2 years ago

  • Category set to Link Handling, Site Handling & Routing
  • Status changed from New to Accepted
#2

Updated by Gerrit Code Review almost 2 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60326

#3

Updated by Daniel Goerz almost 2 years ago

  • Related to Bug #86653: Preview of page, with "show", not working when starttime is set added
#4

Updated by Gerrit Code Review over 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60326

#5

Updated by Gerrit Code Review over 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60326

#6

Updated by Christian Eßl 12 months ago

  • Related to Bug #90842: FE user restriction on pages and link incl. linkAccessRestrictedPages create wrong URLs added
#7

Updated by Gerrit Code Review 12 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63963

#8

Updated by Christian Eßl 11 months ago

  • Has duplicate Bug #91045: Language overlay does not respect $disableGroupAccessCheck added
#9

Updated by Jonas Eberle 10 months ago

I cannot reproduce anymore in 9.5.15.
The preview link for the access restricted translated page is correct.

#10

Updated by Jonas Eberle 10 months ago

Oh, in a special case the bug still exists.

If the parent page is access restricted, too the preview link is wrong.
It is <language prefix of translated language>/<slug of default language>

#11

Updated by Gerrit Code Review 10 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63963

#12

Updated by Gerrit Code Review 10 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63963

#13

Updated by Gerrit Code Review 10 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64359

#14

Updated by Benni Mack 10 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#15

Updated by Gerrit Code Review 10 months ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64359

#16

Updated by Benni Mack 10 months ago

  • Status changed from Under Review to Resolved
#17

Updated by Benni Mack 10 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF