Project

General

Profile

Actions

Bug #91165

closed

New Content Element Wizard Modal not opening in modal box (if you are to fast)

Added by Josef Glatz almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend JavaScript
Target version:
Start date:
2020-04-22
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Problem/Description

I can open the NCEW (triggered from any page module "+ Content" button between existing content elements) without a modal box the last couple of weeks testing/reviewing the TYPO3 master (10.4.x-dev to be specific) and also in real world 10.4.0 LTS projects at least "once" a day. Looks like a race-condition, where maybe any JS listener is to slow, I don't know I can reproduce it now!.

Since I had to get a feeling of when does that mostly appear, I can say now that it's mostly occurs when I do the following steps:

  1. I am logged in in my TYPO3 backend (Chrome, stable, macOS Mojave, DevTools are open with the Elements Tab, Caches are disabled checkbox is on in network tab)
  2. Page module is opened
  3. I close the editing mode of an content element
  4. the page module is reloading
  5. I see the typical page module with content elements on it
  6. I press on any "+ Content" button, but don't wait to long, click as soon as you see the buttons)
  7. I see the following scenario instead of the nice modal with the nice filter functionality:

resulting problematic screen

Some other key points:

  1. I don't know if it also appears if I close the DevTools (I will check it while working on projects)
  2. I don't know if this only occurs on slow computers™ like mine ;-)
  3. The following console log entries exists (but I'm not sure if they exists because of this shown issue)
    • jquery.clearable.js?bust=1587483197:33 jquery.clearable has been marked as deprecated and will be removed in TYPO3 v11. Use TYPO3/CMS/Backend/Input/Clearable and native HTMLInputElement instead.
    • [Deprecation] Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check https://xhr.spec.whatwg.org/.
  4. The content of the NCEW modal is loaded in the #typo3-contentIframe

Acceptance Criteria

  • NCEW modal should open always in modal

NCEW ... New Content Element Wizard


Files

ncew-no-modal-problem-josefglatz.png (172 KB) ncew-no-modal-problem-josefglatz.png resulting problematic screen Josef Glatz, 2020-04-22 07:18

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #91848: modal-dialog by create new content element is brokenClosed2020-07-23

Actions
Actions #1

Updated by Josef Glatz almost 4 years ago

  • Subject changed from New Content Element Wizard Modal not opening in modal box (at least once a day) to New Content Element Wizard Modal not opening in modal box (if you are to fast)
  • Description updated (diff)
Actions #2

Updated by Josef Glatz almost 4 years ago

With some further testing I found out that someone don't have to be very fast to achieve that

Actions #3

Updated by Georg Ringer almost 4 years ago

  • Status changed from New to Accepted
Actions #4

Updated by Benni Mack almost 4 years ago

  • Target version set to next-patchlevel
Actions #5

Updated by Andreas Kienast almost 4 years ago

  • Status changed from Accepted to In Progress
Actions #6

Updated by Gerrit Code Review almost 4 years ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64307

Actions #7

Updated by Gerrit Code Review almost 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64307

Actions #8

Updated by Andreas Fernandez almost 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #9

Updated by Benni Mack almost 4 years ago

  • Status changed from Resolved to Closed
Actions #10

Updated by Gerrit Code Review over 3 years ago

  • Status changed from Closed to Under Review

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65090

Actions #11

Updated by Andreas Kienast over 3 years ago

  • Related to Bug #91848: modal-dialog by create new content element is broken added
Actions #12

Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65090

Actions #13

Updated by Andreas Fernandez over 3 years ago

  • Status changed from Under Review to Resolved
Actions #14

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF