Bug #91241

Backend User has no access to pages in TYPO3 9.5.16 and 10.4.0

Added by König David over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2020-04-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If a user has a mountpoint to some page in the tree and has not access to all pages in the rooline, the listview wont work anymore.

In my case we have a page-tree below "Product Database" and the User has access to one of the subpages.
All subpages of "Product Database" has "ext: hfxyz (S)" as access-group. (See: accesrigths-of-root-pages.jpg)

If the user has no access for pages with the group "xyz-group.ch (S)", then the error occures.
If we add the group ("xyz-group.ch (S)") to the User, all is working fine. But the user has a group he should not have!

This error occures since TYPO3 9.5.16.


Files

list-view-with-page-access-to-all-rooline-pages.jpg (19.4 KB) list-view-with-page-access-to-all-rooline-pages.jpg König David, 2020-04-30 11:02
received-error.jpg (24.7 KB) received-error.jpg König David, 2020-04-30 11:02
list-view-on-error.jpg (16.4 KB) list-view-on-error.jpg König David, 2020-04-30 11:02
accesrigths-of-root-pages.jpg (34.6 KB) accesrigths-of-root-pages.jpg König David, 2020-04-30 11:02

Related issues

Is duplicate of TYPO3 Core - Bug #91221: Pagetree does not show with an editor account and a mounted page in a system folder in Typo3 9.5.16Closed2020-04-28

Actions
#1

Updated by König David over 1 year ago

I can also confirm the same behavior for TYPO3 10.4.1

#2

Updated by König David over 1 year ago

  • Subject changed from Backend User has no access to pages in TYPO3 9.5.16 to Backend User has no access to pages in TYPO3 9.5.16 and 10.4.1
#3

Updated by König David over 1 year ago

  • Subject changed from Backend User has no access to pages in TYPO3 9.5.16 and 10.4.1 to Backend User has no access to pages in TYPO3 9.5.16 and 10.4.0

I can also confirm the same behavior for TYPO3 10.4.0. But it was working in TYPO3 10.3.0

#5

Updated by König David over 1 year ago

  • Is duplicate of Bug #91221: Pagetree does not show with an editor account and a mounted page in a system folder in Typo3 9.5.16 added
#6

Updated by König David over 1 year ago

Yes, i dident see the other Bug. Ups, Sorry!

#7

Updated by Riccardo De Contardi over 1 year ago

  • Status changed from New to Closed

I close this issue as a duplicate of #91221 please continue the discussion there. Thank you.

Also available in: Atom PDF