Bug #91221

Pagetree does not show with an editor account and a mounted page in a system folder in Typo3 9.5.16

Added by Robert Wolle 7 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2020-04-28
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

When I log in with an editor account, the pagetree does not show and an error message is shown (see attached file).

In addition to that, the protocol doesn't show an entry either.

I cleared the cache, deleted the cache files manually, checked for some db updates and nothing worked so far.

Maybe it has something to do with "Respect site for route persisted mappers". It's just a guess.

Kind regards


Files

Bildschirmfoto 2020-04-28 um 13.20.13.png (13.8 KB) Bildschirmfoto 2020-04-28 um 13.20.13.png Robert Wolle, 2020-04-28 13:20
Bildschirmfoto 2020-04-28 um 18.16.07.png (23.2 KB) Bildschirmfoto 2020-04-28 um 18.16.07.png Robert Wolle, 2020-04-28 18:25
group.png (72.3 KB) group.png Robert Wolle, 2020-04-28 18:28
access.png (89.4 KB) access.png Robert Wolle, 2020-04-29 11:02
position_of_page_works.png (22.6 KB) position_of_page_works.png Robert Wolle, 2020-04-29 11:50
before.png (11.5 KB) before.png Robert Wolle, 2020-04-29 17:22
now.png (39 KB) now.png Robert Wolle, 2020-04-29 17:22

Related issues

Related to TYPO3 Core - Task #90880: Filter pages user has access to on query timeClosed2020-03-30

Actions
Related to Backend ACLs - Bug #91632: Update to 9.5.19 + recursive permissionsResolved2020-06-10

Actions
Related to TYPO3 Core - Bug #91753: Pagetree not respecting getPagePermsClause()Closed2020-07-06

Actions
Has duplicate TYPO3 Core - Bug #91241: Backend User has no access to pages in TYPO3 9.5.16 and 10.4.0Closed2020-04-30

Actions
#1

Updated by Robert Wolle 7 months ago

It seems, that if you have a root page assigned, the error occurs. If you assign a page inside a page root, everything works fine. But we have groups for multiple root pages. So I don't know, what to do.

#2

Updated by Robert Wolle 7 months ago

  • Subject changed from Pagetree does not show with an editor account in Typo3 9.5.16 to Pagetree does not show with an editor account and a mounted root page in Typo3 9.5.16
#3

Updated by Georg Ringer 7 months ago

  • Is Regression set to Yes
#4

Updated by Tymoteusz Motylewski 7 months ago

Hi Robert
Thanks for the report.
Can you explain the "that if you have a root page assigned, "?
Are you saying you have root page (the one with TYPO3 logo, uid=0) assigned to the user group?
Can you attach a screenshot from group configuration? And what is stored in the db for fields be_users.db_mountpoints and be_groups.db_mountpoints ?

AFAIK it's possible to select root page (uid=0) as a db mount for editor or editor group.

#5

Updated by Robert Wolle 7 months ago

Hi Tymoteusz,

the root pages have the flag is_siteroot always and a yaml configuration is set.
We assign at least one of these pages to the db_mountpoints. be_users.db_mountpoints are not used, be_groups.db_mountpoints only. We are in pagetree level > 1 (see screenshot). But the level doesn't matter. In a different system there is the same behavior with the page on level 1.

When I select a page inside, which has no is_siteroot flag, it works.

For our user groups we have a hierarchical theme:

all user (no mounts are set)
  -> editor group (width multiple rights; no mounts are set)
    -> page group (explicit mount is set)

With over 170 user and 70 depending usergroups it is not possible to select root page (uid=0) as a db mount. Each page is an individual website.

Thank you and kind regards

#6

Updated by Thomas Oliver Moll 7 months ago

I can confirm there is a Problem.

I did not see the red error message myself but it was reported to me.

But the real Problem here is, that my Editors, which are in multiple groups that inherit various DB-mounts, only see their page tree last mount point (i.e. the one that gets added last) in the page tree. As if the mount points are not added to the list but replace the list:

This is our setup
  • Group A (DB mount A)
  • Group B (DB mount B)
  • ...
  • Group K (DB mount K)
  • MasterGroup (inheriting Group A-K, DB mount L, DB mount M, DB mount N)

None of the mount point pages have is_siteroot set, they are sub pages of a sub site.
One of the mount points is a sys folder ... let's call it "DB mount J" in the example so it's smack in the middle of the List

Only DB mount N is showing up in the page tree for members if the MasterGroup

For Admins everything looks fine.

In 9.5.15 the Editors in the MasterGroup can see DB mount A-N

#7

Updated by Thomas Oliver Moll 7 months ago

  • PHP Version changed from 7.2 to 7.3
#8

Updated by Tymoteusz Motylewski 7 months ago

Hi
I'm investigating the topic.
I managed to reproduce the issue with red error when user did not have access to the page listed as db mount.
Can you please check if this is also the case in your installation?

#9

Updated by Robert Wolle 7 months ago

Hi,

the rights for the pages are set. Each page has their own group assigned (see screenshot).

Kind regards

#10

Updated by Tymoteusz Motylewski 7 months ago

Another issue I see, which is really a bug is that when the mounted page is under not accessible page it will not be shown.

#11

Updated by Robert Wolle 7 months ago

I got it. If the page is in a sys folder on level 2, the pagetree will not get generated. When I move the site root under page uid = 0 on level 1, it'll work. But as I said. We have over 70 pages in the system and they have to be sorted in sys folder for organization.
So it has nothing to do with the is_siteroot flag. I'm sorry.

Kind regards
Robert

#12

Updated by Robert Wolle 7 months ago

  • Subject changed from Pagetree does not show with an editor account and a mounted root page in Typo3 9.5.16 to Pagetree does not show with an editor account and a mounted page in a system folder in Typo3 9.5.16
#13

Updated by Gerrit Code Review 7 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64346

#14

Updated by Tymoteusz Motylewski 7 months ago

I have pushed a POC patch. Please check if it solves the issue for you.

#15

Updated by Robert Wolle 7 months ago

The issue is solved, but the look did change (arrow before the globe; see screenshots). I know it's a cosmetic thing, but should be adapt so that the sub pages are always expanded and no possibility to fold the site root.
Thank you so far.

#16

Updated by König David 7 months ago

  • Has duplicate Bug #91241: Backend User has no access to pages in TYPO3 9.5.16 and 10.4.0 added
#17

Updated by König David 7 months ago

The same Problem exist also in TYPO3 10 since 10.4.0. as i wrote in the duplicated Issue.

The Related Patch set 1 works for us on TYPO3 9.5.16 and 10.4.1. Thanks!

#18

Updated by Thomas Oliver Moll 7 months ago

Patch seems to fix the issue, thanks

#19

Updated by Patrick Schriner 7 months ago

My guess would be this was caused by https://forge.typo3.org/issues/90880 ?

#20

Updated by Gerrit Code Review 7 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64346

#21

Updated by Tymoteusz Motylewski 7 months ago

  • Related to Task #90880: Filter pages user has access to on query time added
#22

Updated by Tymoteusz Motylewski 7 months ago

Robert Lemke
Are you sure the arrow has changed between 9.5.15 and 9.5.16?
I've just tested it in 9.5.15 and I see the same arrows and in the same places as in 9.5.16

#23

Updated by Gerrit Code Review 7 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64346

#24

Updated by Robert Wolle 7 months ago

Hi Tymoteusz,

I'm sorry. I forgot to tell you, that it was a cache issue on my part.

Currently we have to use 9.5.13, because of two bugs regarding multisite setups. One is solved yet. ;-)

Thank you for your effort!

Kind regards

#25

Updated by Gerrit Code Review 7 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64346

#26

Updated by Gerrit Code Review 7 months ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64346

#27

Updated by Gerrit Code Review 6 months ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64346

#28

Updated by Gerrit Code Review 6 months ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64346

#29

Updated by Gerrit Code Review 6 months ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64346

#30

Updated by Gerrit Code Review 6 months ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64639

#31

Updated by Tymoteusz Motylewski 6 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#32

Updated by Gerrit Code Review 6 months ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64640

#33

Updated by Tymoteusz Motylewski 6 months ago

  • Status changed from Under Review to Resolved
#34

Updated by Gerrit Code Review 6 months ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64640

#35

Updated by Tymoteusz Motylewski 6 months ago

  • Status changed from Under Review to Resolved
#36

Updated by Torben Hansen 5 months ago

  • Related to Bug #91632: Update to 9.5.19 + recursive permissions added
#37

Updated by Torben Hansen 5 months ago

  • Related to Bug #91753: Pagetree not respecting getPagePermsClause() added
#38

Updated by Benni Mack 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF