Bug #91429

Initlialisation of $this->where_groupAccess missing in init method of TYPO3\CMS\Frontend\Page\PageRepository

Added by Thomas Hohn 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
Start date:
2020-05-18
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

It seems that the condition

$this->where_groupAccess = '';

was deleted by accident in the init method. This missing initialisation seems to break the SOLR indexing of
pages with access restricted groups.


Related issues

Related to TYPO3 Core - Bug #91208: Performance issue in PageRepository for Mega MenusClosedStefan Froemken2020-04-27

Actions
#2

Updated by Oliver Hader 6 months ago

  • Related to Bug #91208: Performance issue in PageRepository for Mega Menus added
#3

Updated by Oliver Hader 6 months ago

  • Category set to Frontend
#4

Updated by Gerrit Code Review 6 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64516

#5

Updated by Mathias Brodala 6 months ago

  • Is Regression set to Yes
#6

Updated by Gerrit Code Review 6 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64516

#7

Updated by Oliver Hader 6 months ago

  • Is Regression deleted (Yes)
#8

Updated by Oliver Hader 6 months ago

After looking closer to the whole class, it looks like the initialization was removed on purpose - since it's overridden in TYPO3 v9's constructor.
What are the effects, warnings, error when indexing with ext:sorl? Could you please provide a stack-trace (if available)? Thx in advance!

#9

Updated by Thomas Hohn 6 months ago

  • Is Regression set to Yes
#10

Updated by Thomas Hohn 6 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#11

Updated by Gerrit Code Review 6 months ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64523

#12

Updated by Benni Mack 6 months ago

  • Status changed from Under Review to Resolved
#13

Updated by Benni Mack 6 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF