Bug #91446

Composer update -> "TYPO3\CMS\Install\Service\LateBootService" is not available.

Added by Malte Nintz over 1 year ago. Updated 10 months ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
System/Bootstrap/Configuration
Target version:
-
Start date:
2020-05-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi there,
ive got trouble with composer and updating typo3 from 10.4.2 to 10.4.3.

Ive tried a full reset of vendor folder but it results in the same error.
Ive deactivated all extensions ... same error.

Output:

  - Installing georgringer/news (8.3.0): Loading from cache
  - Installing helhum/config-loader (v0.12.2): Loading from cache
  - Installing symfony/process (v5.0.8): Loading from cache
  - Installing helhum/typo3-console (v6.3.0): Loading from cache
  - Installing kronova/pr-teamspeak (3.0.1): Loading from cache
  - Installing typo3/cms-about (v10.4.3): Loading from cache
  - Installing typo3/cms-viewpage (v10.4.3): Loading from cache
  - Installing typo3/cms-tstemplate (v10.4.3): Loading from cache
  - Installing typo3/cms-t3editor (v10.4.3): Loading from cache
  - Installing typo3/cms-sys-note (v10.4.3): Loading from cache
  - Installing typo3/cms-setup (v10.4.3): Loading from cache
  - Installing typo3/cms-info (v10.4.3): Loading from cache
  - Installing typo3/cms-impexp (v10.4.3): Loading from cache
  - Installing typo3/cms-form (v10.4.3): Loading from cache
  - Installing typo3/cms-filelist (v10.4.3): Loading from cache
  - Installing typo3/cms-felogin (v10.4.3): Loading from cache
  - Installing typo3/cms-dashboard (v10.4.3): Loading from cache
  - Installing typo3/cms-beuser (v10.4.3): Loading from cache
  - Installing typo3/cms-belog (v10.4.3): Loading from cache
symfony/event-dispatcher suggests installing symfony/http-kernel
symfony/dependency-injection suggests installing symfony/proxy-manager-bridge (Generate service proxies to lazy load them)
symfony/console suggests installing symfony/lock
guzzlehttp/psr7 suggests installing zendframework/zend-httphandlerrunner (Emit PSR-7 responses)
doctrine/cache suggests installing alcaeus/mongo-php-adapter (Required to use legacy MongoDB driver)
symfony/property-info suggests installing symfony/doctrine-bridge (To use Doctrine metadata)
symfony/property-info suggests installing symfony/serializer (To use Serializer metadata)
typo3/cms-extbase suggests installing typo3/cms-scheduler (Additional scheduler tasks)
typo3/cms-frontend suggests installing typo3/cms-adminpanel (Provides additional information and functionality for backend users in the frontend.)
georgringer/news suggests installing reelworx/rx-shariff (^12 || ^13)
helhum/config-loader suggests installing ext-yaml (For improved performance when parsing yaml files you should use the PECL YAML Parser php extension)
Generating autoload files
Generating class alias map file
> typo3cms install:fixfolderstructure

  [ TYPO3\CMS\Core\DependencyInjection\NotFoundException ]
  Container entry "TYPO3\CMS\Install\Service\LateBootService" is not availabl
  e.

install:fixfolderstructure

Script typo3cms install:fixfolderstructure handling the typo3-cms-scripts event returned with error code 255
Script @typo3-cms-scripts was called via post-autoload-dump

Is there an Problem in composer repro?


Files

Download.png (198 KB) Download.png composer output Malte Nintz, 2020-05-20 08:44
update.gif (7.83 MB) update.gif gif of composer update Malte Nintz, 2020-05-20 08:47
composer.gz (19.4 KB) composer.gz Vasyl Mosiychuk, 2020-11-13 12:04
#1

Updated by Malte Nintz over 1 year ago

Malte Nintz wrote:

Hi there,
ive got trouble with composer and updating typo3 from 10.4.2 to 10.4.3.

Ive tried a full reset of vendor folder but it results in the same error.
Ive deactivated all extensions ... same error.

Output:
[...]

Is there an Problem in composer repro?

And some hours later it seemed to be fixed. Composer update works like a charm.

closed...

#2

Updated by Sven Nußbaum over 1 year ago

Malte Nintz wrote:

Malte Nintz wrote:

Hi there,
ive got trouble with composer and updating typo3 from 10.4.2 to 10.4.3.

Ive tried a full reset of vendor folder but it results in the same error.
Ive deactivated all extensions ... same error.

Output:
[...]

Is there an Problem in composer repro?

And some hours later it seemed to be fixed. Composer update works like a charm.

closed...

I have the same issue after updating from 10.4.2 to 10.4.3

#3

Updated by Bastian Bringenberg over 1 year ago

  • Project changed from forge.typo3.org to TYPO3 Core
  • Category deleted (Server Administration)
  • Target version deleted (0.3)
  • TYPO3 Version set to 10

Moved to correct project.

#4

Updated by Georg Ringer about 1 year ago

  • Status changed from New to Closed

can't reproduce that. if still occurs, please drop a note in the typo3 slack channel or create a new issue and add your composer.json + composer.lock file

#5

Updated by Markus Klein 12 months ago

  • Status changed from Closed to New

I have the same issue after an update from 10.4.8 to 10.4.9 and a rollback afterwards

#6

Updated by Markus Klein 12 months ago

Turns out the PackageStates.php file got damaged. So something within the composer setup process is the root cause.

#7

Updated by Markus Klein 11 months ago

  • Category set to System/Bootstrap/Configuration
#8

Updated by Vasyl Mosiychuk 10 months ago

I have the same issue after updating from 10.4.9 to 10.4.??

typo3cms install:fixfolderstructure

sh: 1: typo3cms: not found

Script typo3cms install:fixfolderstructure handling the typo3-cms-scripts event returned with error code 127

Script @typo3-cms-scripts was called via post-autoload-dump

Also available in: Atom PDF