Bug #91889

AssetRenderer does not respect FE.versionNumberInFilename

Added by Torben Hansen about 1 year ago. Updated 10 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2020-07-29
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The AssetRenderer for the new AssetCollector in TYPO3 10.4 does not respect the $GLOBALS['TYPO3_CONF_VARS']['FE']['versionNumberInFilename'] setting.

This is a problem, when rendered assets (e.g. JavaScript files) are rendered and cached on the client. When the content of the asset changes server side, the client will not reload the updated asset, since the filename is the same.

We should use GeneralUtility::createVersionNumberedFilename in AssetRenderer::getAbsoluteWebPath() so versioned file names are created.


Related issues

Related to TYPO3 Core - Bug #91219: AssetCollector (or Renderer) does not consider [FE][versionNumberInFilename]ClosedJonas Eberle2020-04-28

Actions
#1

Updated by Gerrit Code Review 12 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65238

#2

Updated by Gerrit Code Review 12 months ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65255

#3

Updated by Georg Ringer 12 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#4

Updated by Georg Ringer 10 months ago

  • Related to Bug #91219: AssetCollector (or Renderer) does not consider [FE][versionNumberInFilename] added
#5

Updated by Benni Mack 10 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF