Project

General

Profile

Actions

Bug #92245

closed

CKEditor: Table wrapped around links when linking a text in a table (Chrome)

Added by Ludovic Nogueira almost 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2020-09-09
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
requirejs
Complexity:
Is Regression:
Sprint Focus:

Description

Hello,

In TYPO3 9.20, tested on a fresh install, if you select all the text in a cell and then make a link, CKeditor will create a new table in this cell.
It does not happen if I test it on the CKeditor website: https://nightly.ckeditor.com/20-09-01-06-04/full/samples/

Easy to reproduce, select all the text, select your link (see screenshot)

Note: This was discovered in Chrome browser (verified in Chromium 87.0.4280.66).


Files

linkckeditor.png (11.6 KB) linkckeditor.png Ludovic Nogueira, 2020-09-09 14:06
ckeditor2.png (11.3 KB) ckeditor2.png Ludovic Nogueira, 2020-09-16 08:37
ckeditor3.png (25.3 KB) ckeditor3.png Ludovic Nogueira, 2020-09-16 08:37
ckeditor1.png (26.6 KB) ckeditor1.png Ludovic Nogueira, 2020-09-16 08:37
table-link-bug.gif (208 KB) table-link-bug.gif Mario Lubenka, 2021-01-27 11:25

Related issues 1 (1 open0 closed)

Related to TYPO3 Core - Bug #100046: Creating a link within an RTE CKEditor table cell without having any text selected merges this table cell with a neighboring cellNew2023-02-28

Actions
Actions #1

Updated by Riccardo De Contardi almost 4 years ago

I am not able to reproduce it on 9.5.21 - no special config; I just use

RTE.default.preset = full 
Actions #2

Updated by Riccardo De Contardi almost 4 years ago

  • Category set to RTE (rtehtmlarea + ckeditor)

Updated by Ludovic Nogueira almost 4 years ago

Okay, maybe I know why you can't reproduce it. What kind of popup do you have? The basic CKeditor or the TYPO3 linking system? When using the last one I have the bug I mentionned. (see screenshot)

You can reproduce it here: https://buchs.typo3-cms-test.de/typo3 login info: https://www.typo3-cms-test.de/start/zugangsdaten/

Actions #4

Updated by Riccardo De Contardi almost 4 years ago

@Ludovic Nogueira I use TYPO3's one; I will try on my system with an editor (I tested with admin).

Actions #5

Updated by Riccardo De Contardi almost 4 years ago

@Ludovic Nogueira I am still not able to reproduce it, even with default preset and an editor user :(

I've found a difference between your system and mine (I logged in in your backend with your instructions):

In my backend, when I create a new table in the editor, it is 100% wide and with collapsed border, while in yours it is not;

In my case, the file /typo3/sysext/rte_ckeditor/Resources/Public/Css/contents.css is loaded

Actions #6

Updated by Mario Lubenka over 3 years ago

We also discovered that behaviour in Chrome Browser only (using TYPO3 9.5.24).

Actions #7

Updated by Mario Lubenka over 3 years ago

  • Subject changed from CKeditor link in table to CKEditor: Table wrapped around links when linking a text in a table (Chrome)
  • Description updated (diff)
  • Target version set to next-patchlevel

So this is definitely an issue with the "typo3link" plugin (or the used TYPO3 JS modules in there).
I disabled the plugin, leaving me with the default link plugin from CKEditor which works fine.

I'm currently looking into this issue, however I don't have much experience in CKEditor or the TYPO3 JS backend components.
I'd appreciate any help. ^^

Actions #8

Updated by Mario Lubenka over 3 years ago

Recorded on TYPO3 CMS 9.5.23 with Chromium v87.0.4280.66

This seems to be some issue with CKEditor, as the element inserted into the editor is created with CKEditor.
The following seems to work:

sysext:rte_ckeditor/Resources/Public/JavaScript/RteLinkBrowser.js

-RteLinkBrowser.CKEditor.insertElement(linkElement);
+RteLinkBrowser.CKEditor.insertHtml(linkElement.getOuterHtml());

I'll do testing with some more browsers and try to provide a pull request for that.

Actions #9

Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67543

Actions #10

Updated by Mario Lubenka about 3 years ago

This issue could not be reproduced in latest 10.4.14 release.

Since version 9 will only receive emergency updates for critical issues, it is encouraged to upgrade to latest TYPO3 10 version to fix this issue.

Actions #11

Updated by Benni Mack about 3 years ago

  • Status changed from Under Review to Closed

Thanks for the feedback, Mario!

Actions #12

Updated by Georg Ringer over 1 year ago

  • Related to Bug #100046: Creating a link within an RTE CKEditor table cell without having any text selected merges this table cell with a neighboring cell added
Actions

Also available in: Atom PDF