Project

General

Profile

Actions

Bug #92444

closed

FAL Error when accessing file in subfolder of new sys_file_storage

Added by Christophe Monard over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2020-09-29
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
FAL sys_file_storage
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Create a new sys_file_storage pointing to directory outside fileadmin.
Files and folder are shown correctly
But when you try to access file in subdirectory of the new sys_file_storage, TYPO3 crash.
Frontend template using files of alternative sys_file_storage crash also.

Worked well under TYPO3 10.4.8, broken in TYPO3 10.4.9

Accessing files in root directory of the new sys_file_storage work well. Only files in subfolder are affected.


Files

fileaccess-10.9.png (120 KB) fileaccess-10.9.png File in subfolder unaccessible (TYPO3 10.4.9) Christophe Monard, 2020-09-29 16:44
fileaccess-10.8.png (155 KB) fileaccess-10.8.png File in subfolder accessible (TYPO3 10.4.8) Christophe Monard, 2020-09-29 16:44
storage-files.png (19.2 KB) storage-files.png File module listing files and folder properly Christophe Monard, 2020-09-29 16:44
assets-1.png (67.1 KB) assets-1.png General Christophe Monard, 2020-09-30 10:43
assets-2.png (26.7 KB) assets-2.png Access right Christophe Monard, 2020-09-30 10:43
assets-3.png (9.63 KB) assets-3.png Access Christophe Monard, 2020-09-30 10:43

Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #92014: Move SVG image processing into an own file processorClosed2020-08-15

Actions
Related to TYPO3 Core - Bug #92862: Patch #92014 still not merged in last release and SVG aren't handled properlyClosed2020-11-17

Actions
Actions #1

Updated by Daniel Goerz over 3 years ago

  • Description updated (diff)
Actions #2

Updated by Helmut Hummel over 3 years ago

  • Status changed from New to Needs Feedback

Can you please provide the exact configuration of the storage that causes issues for you?
How is the file location configured (absolute/relative)? What is the absolute path of this storage related to the absolute path of fileadmin?
What options are set (readolny, public, ...)?

Updated by Christophe Monard over 3 years ago

Here is the configuration of the sys_file_storage created for our resources (cf additional screenshot) :

- driver : local
- Base path : typo3conf/ext/arc_project/Resources/Public/boilerplate/dist/prod/assets/img/
- Type : relative
- use case sensitive : yes
- is default : no
- auto extract metadata : no
- processing folder : 1:_processed_
- is browsable : yes
- is public : yes 
- is writable : no
- is online : yes

I tried to remove the processing folder and add write permission on it without success.
Files in root directory are accessible but files in sub directory aren't viewable.

I rolled back to 10.4.8 in order to get functionnal website.



Actions #4

Updated by Helmut Hummel over 3 years ago

  • Related to Bug #92014: Move SVG image processing into an own file processor added
Actions #5

Updated by Gerrit Code Review over 3 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65963

Actions #6

Updated by Helmut Hummel over 3 years ago

I tried to remove the processing folder and add write permission on it without success

Thanks providing the config helped to reproduce this issue. In fact this is a bug that existed before but never fully surfaced.
The attached change now fully fixes the issue (e.g. you will see preview thumbs of the SVGs in this storage again, which was not working in 10.4.8 either).

Actions #7

Updated by Christophe Monard over 3 years ago

Helmut Hummel wrote:

I tried to remove the processing folder and add write permission on it without success

Thanks providing the config helped to reproduce this issue. In fact this is a bug that existed before but never fully surfaced.
The attached change now fully fixes the issue (e.g. you will see preview thumbs of the SVGs in this storage again, which was not working in 10.4.8 either).

Thanks Helmut!
I will wait for next T3 release and make feedback.
If i gave time i will patch development plateform in order to test if it's ok now

Actions #8

Updated by Helmut Hummel over 3 years ago

Christophe Monard wrote:

I will wait for next T3 release and make feedback.
If i gave time i will patch development plateform in order to test if it's ok now

Feedback before a release would be great. Thanks.

I also have a question regarding your use case for such storage:

What do you use this storage exactly for? How are the files in there actually used?

Actions #9

Updated by Christophe Monard over 3 years ago

Helmut Hummel wrote:

Christophe Monard wrote:

I will wait for next T3 release and make feedback.
If i gave time i will patch development plateform in order to test if it's ok now

Feedback before a release would be great. Thanks.

I also have a question regarding your use case for such storage:

What do you use this storage exactly for? How are the files in there actually used?

Mainly cause I’m lazy and don’t want to copy all useful resources between front end kit and fileadmin.
Logo and partner logo / optimized picture are stored there and can be included everywhere without duplicating folder contents.

I will try the patch tomorrow and keep you in touch.

Actions #10

Updated by Hartmut Steglich over 3 years ago

same problem and use case here:

Actions #11

Updated by Christophe Monard over 3 years ago

Helmut Hummel wrote:

Christophe Monard wrote:

I will wait for next T3 release and make feedback.
If i gave time i will patch development plateform in order to test if it's ok now

Feedback before a release would be great. Thanks.

I also have a question regarding your use case for such storage:

What do you use this storage exactly for? How are the files in there actually used?

Hi Helmut,

The patch solve the problem for me.
Thanks :)

Actions #12

Updated by Hartmut Steglich over 3 years ago

Hi, works for mee too.

Thanks

Actions #13

Updated by Gerrit Code Review over 3 years ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66674

Actions #14

Updated by Helmut Hummel over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #15

Updated by Oliver Hader over 3 years ago

  • Related to Bug #92862: Patch #92014 still not merged in last release and SVG aren't handled properly added
Actions #16

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF