Bug #92708

Editors cannot copy records in page module

Added by Marcus Schwemer over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2020-10-26
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,

as the subject says, editors cannot copy records / content elements in the page module any more. The entry in the context menu has gone.

How to reproduce:

- create a new TYPO3 (v10 or master)
- create an editor with the permission to view and copy elements on a page
- switch to the editor
- go to the page module
- open the context menu for a record on that page => copy element is missing

Further findings:

- TYPO3 admins can copy a record on via the context menu in page module
- editors can copy the content element in the list module via the copy button
- if an editor has "edit" permissions for records on the page, the "copy" element in the context menu is shown.

Affected TYPO3 versions: TYPO3 V11 and V10 at least (did not check V9)


Files


Related issues

Has duplicate TYPO3 Core - Bug #92729: ContextMenu - copy content item is missing (page group access: Show page: Show/Copy page and content)Closed2020-10-28

Actions
#1

Updated by Oliver Bartsch over 1 year ago

  • Has duplicate Bug #92729: ContextMenu - copy content item is missing (page group access: Show page: Show/Copy page and content) added
#2

Updated by Joerg Boesche over 1 year ago

Here are some screenshots of the described issue.

The editor is logged in and opens the web -> page modul and clicks on a page with the permission "Show page: Show/Copy page and content."
Now the editor clicks on the icon of the content element and the context menu is visible. The context menu item "copy" is still missing.
see attached file: t3_backend_content-element_context-menu-copy.png


#3

Updated by Dmitry Dulepov over 1 year ago

This also happens in TYPO3 9 and 10. The problem is at https://github.com/TYPO3/TYPO3.CMS/blob/master/typo3/sysext/backend/Classes/ContextMenu/ItemProviders/RecordProvider.php#L607:

    protected function canBeCopied(): bool
    {
        return !$this->isRecordInClipboard('copy')
            && $this->canBeEdited()
            && !$this->isRecordATranslation();
    }

A call to $this->canBeEdited() is not needed here because copy is a read-only action.

#4

Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66556

#5

Updated by Gerrit Code Review about 1 year ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68864

#6

Updated by Gerrit Code Review about 1 year ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68865

#7

Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68864

#8

Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68865

#9

Updated by Dmitry Dulepov about 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#10

Updated by Gerrit Code Review about 1 year ago

  • Status changed from Resolved to Under Review

Patch set 3 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68864

#11

Updated by Gerrit Code Review about 1 year ago

Patch set 3 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/68865

#12

Updated by Dmitry Dulepov about 1 year ago

  • Status changed from Under Review to Resolved
#13

Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF