Project

General

Profile

Actions

Bug #93176

closed

Epic #89595: Improve accessibility of backend

BE login needs accessible replacement for stateful Bootstrap buttons

Added by Martin Kutschker over 3 years ago. Updated 24 days ago.

Status:
Closed
Priority:
Should have
Category:
Backend User Interface
Target version:
-
Start date:
2020-12-27
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
accessibility, bootstrap5
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

The BE login submit button used the data-loading-text atttribute during validation of the credentials.

Stateful buttons have been deprecated in Boostrap 3.3 and removed in Bootstrap 4:

https://getbootstrap.com/docs/3.3/javascript/#buttons-stateful

The new implementation should not bring the button back, but provide a better and accessible alternative.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Epic #93119: Bootstrap v5 migrationClosed2020-12-20

Actions
Actions #1

Updated by Martin Kutschker over 3 years ago

Actions #2

Updated by Martin Kutschker over 3 years ago

  • Related to Epic #89595: Improve accessibility of backend added
Actions #3

Updated by Benjamin Franzke over 3 years ago

  • Parent task set to #89595
Actions #4

Updated by Stephan Großberndt over 3 years ago

  • Subject changed from BE login needs accessible replacment for stateful Boostrap buttons. to BE login needs accessible replacement for stateful Bootstrap buttons
Actions #5

Updated by Frank Nägler about 1 year ago

  • Tags changed from accessibility bootstrap5 to accessibility, bootstrap5
Actions #6

Updated by Garvin Hicking 24 days ago

  • Status changed from New to Closed

Since current TYPO3 versions v12+v13 use Bootstrap v5 already and the BE login button has been adressed with the current javascript framework I'd say it is ok to close this issue?

Please let me know if you believe this is an error and we can re-open or create a follow-up. Thank you!

Actions

Also available in: Atom PDF