Bug #93203

Epic #95236: Backend UI layout issues

BE Form Styling Firefox Linux

Added by Tomas Norre Mikkelsen 10 months ago. Updated 25 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2021-01-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi.

After Updating to TYPO3 11.0 the login mask isn't looking quite right on Firefox Linux.
I Know we are not the main group of editors, but we should give it a look anyway.

For Opera and Vivaldi it looks like expected. I Have attached screenshots of all 3 login masks.


Files

login_firefox_linux.png (11.1 KB) login_firefox_linux.png Tomas Norre Mikkelsen, 2021-01-02 07:05
login_opera_linux.png (11.3 KB) login_opera_linux.png Tomas Norre Mikkelsen, 2021-01-02 07:05
login_vivaldi_linux.png (12 KB) login_vivaldi_linux.png Tomas Norre Mikkelsen, 2021-01-02 07:05
search_be_firefox_linux.png (5.84 KB) search_be_firefox_linux.png Tomas Norre Mikkelsen, 2021-01-02 07:15
TemplateTitle_Firefox_linux.png (4.45 KB) TemplateTitle_Firefox_linux.png Tomas Norre Mikkelsen, 2021-01-02 07:35
startTime_Firefox_linux.png (2.29 KB) startTime_Firefox_linux.png Tomas Norre Mikkelsen, 2021-01-02 07:35
checkbox_firefox_linux.png (10.4 KB) checkbox_firefox_linux.png Tomas Norre Mikkelsen, 2021-01-02 07:44
firefox-typo3-v11.png (179 KB) firefox-typo3-v11.png Marcin Sągol, 2021-08-12 11:33
starttime_firefox_91.0_ubuntu_2104.png (5.39 KB) starttime_firefox_91.0_ubuntu_2104.png Tomas Norre Mikkelsen, 2021-08-12 14:06
clipboard-202109211839-t8xmh.png (2.9 KB) clipboard-202109211839-t8xmh.png Jonas Eberle, 2021-09-21 16:39
#1

Updated by Tomas Norre Mikkelsen 10 months ago

Looks like there are some BE Forms issues on Firefox Linux in General.

#2

Updated by Tomas Norre Mikkelsen 10 months ago

It looks like a general problem with input type=text fields for Firefox Linux.

#3

Updated by Tomas Norre Mikkelsen 10 months ago

  • Subject changed from Form Styling Firefox Linux to BE Form Styling Firefox Linux
#4

Updated by Tomas Norre Mikkelsen 10 months ago

And some of the checkboxes are off.

#5

Updated by Benni Mack 8 months ago

  • Target version changed from 11.1 to 11.2
#6

Updated by Benni Mack 5 months ago

  • Target version changed from 11.2 to 11.3
#7

Updated by Benni Mack 3 months ago

  • Target version changed from 11.3 to 11.4
#8

Updated by Marcin Sągol 2 months ago

I will check this one.

#9

Updated by Marcin Sągol 2 months ago

I have tested it on Firefox 92 and 89 using branches master , v11.0.0 , v11.2.0 on Ubuntu 21.04 and can't reproduce the issue.
Mentioned elements are rendered fine.

#10

Updated by Tomas Norre Mikkelsen 2 months ago

Thanks for testing. It's some time ago so don't recall the Firefox version.

I'll do a retest, with my Firefox Ubuntu 21.04 and if not a problem any more we will close. It can of course also be my browser.

#11

Updated by Rudy Gnodde 2 months ago

Can't reproduce it either in Firefox 91 on Ubuntu 20.04

#12

Updated by Stefan Bürk 2 months ago

Can't reproduce it with Firefox 90.0.2 64bit under Linux Mint (Ubuntu 20.04)

#13

Updated by Tomas Norre Mikkelsen 2 months ago

For me it's working way better than before to.

Only a little minor thing I saw.

The box for e.g. Starttime isn't the same height as the button-icon right to it. (see image)

#14

Updated by Benni Mack about 1 month ago

  • Target version changed from 11.4 to 11 LTS
#15

Updated by Paul Hansen about 1 month ago

  • Parent task set to #95236
#16

Updated by Jonas Eberle 27 days ago

I can't reproduce in current master (and have also not seen it before) with FF 92 (Kubuntu 20.4 if it matters).

@Tomas I suspect you have a browser plugin that's manipulating form elements (password plugin?).

#17

Updated by Tomas Norre Mikkelsen 27 days ago

I shouldn't have, but haven't been able to reproduce this again.

So perhaps we should close this for now, and have it reopened in case it re-appears.

#18

Updated by Jonas Eberle 25 days ago

  • Status changed from New to Closed

Thank you.

Also available in: Atom PDF