Bug #93238

Regression: After deleting image in record "add" button is not displayed again

Added by Chris Müller 10 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2021-01-07
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

I have a TCA configuration for a record, where one image must be added:

'image' => [
    // ...
    config => \TYPO3\CMS\Core\Utility\ExtensionManagementUtility::getFileFieldTCAConfig(
        'image',
        [
            'appearance' => [
                'createNewRelationLinkTitle' => 'LLL:EXT:frontend/Resources/Private/Language/locallang_ttc.xlf:images.addFileReference',
            ],
            'foreign_match_fields' => [
                 'fieldname' => 'image',
                 'tablenames' => 'tx_myext_domain_model_table',
                 'table_local' => 'sys_file',
            ],
            'maxitems' => 1,
            'minitems' => 1,
        ],
        $GLOBALS['TYPO3_CONF_VARS']['GFX']['imagefile_ext']
    )
]

When I delete the image, the "Add" button is not displayed again.

This error was introduced with TYPO3 10.4.11, in 10.4.10 it worked like it should.

It seems, it was introduced with #91595.


Related issues

Related to TYPO3 Core - Bug #91595: Not all elements displayed as button behave like buttonsClosed2020-06-05

Actions
Is duplicate of TYPO3 Core - Bug #93091: Missing "Create new relation"-buttons after deleting the former relationClosed2020-12-16

Actions
#1

Updated by Chris Müller 10 months ago

  • Related to Bug #91595: Not all elements displayed as button behave like buttons added
#2

Updated by Karavas Aristeidis 10 months ago

It is worth mentioning that this happens (AFAIK) when the limit is set to 1

#3

Updated by Česlav Przywara 10 months ago

This issue has already been reported - see #93091.

#4

Updated by Česlav Przywara 10 months ago

  • Is duplicate of Bug #93091: Missing "Create new relation"-buttons after deleting the former relation added
#5

Updated by Gerrit Code Review 9 months ago

  • Status changed from New to Under Review

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67541

#6

Updated by Gerrit Code Review 9 months ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67542

#7

Updated by Gerrit Code Review 9 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67541

#8

Updated by Benni Mack 9 months ago

  • Status changed from Under Review to Resolved
#9

Updated by Benni Mack 8 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF