Bug #93091

Missing "Create new relation"-buttons after deleting the former relation

Added by Julian Hofmann 9 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2020-12-16
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

The following field is configured:

'file' => [
    'label' => 'File',
    'config' => \TYPO3\CMS\Core\Utility\ExtensionManagementUtility::getFileFieldTCAConfig(
        'file',
        [
            'minitems' => 1,
            'maxitems' => 1,
            'foreign_match_fields' => [
                'fieldname' => 'file',
                'tablenames' => 'tx_example_domain_model_example',
                'table_local' => 'sys_file',
            ],
        ],
        '',
        'php,php(3-8)'
    ),
],

While editing a record and deleting an existing file relation, there's no button to add a new relation shown anymore.

Till TYPO3 v10.4.10 the backend looks like this after deleting the relation:

Since TYPO3 v10.4.11 the backend looks like this after deleting the relation:


Files

since_TYPO3_v10.4.11.png (7.54 KB) since_TYPO3_v10.4.11.png Julian Hofmann, 2020-12-16 16:11
till_TYPO3_v10.4.10.png (12.5 KB) till_TYPO3_v10.4.10.png Julian Hofmann, 2020-12-16 16:11

Related issues

Related to TYPO3 Core - Bug #91808: Nested IRRE with maxitems hides last inline control button / toggles inline control buttons wrongClosed2020-07-16

Actions
Has duplicate TYPO3 Core - Bug #93238: Regression: After deleting image in record "add" button is not displayed againClosed2021-01-07

Actions
Has duplicate TYPO3 Core - Bug #93479: TCA inline file with maxitems to 1, can't add after deleteClosed2021-02-10

Actions
#1

Updated by Tobias Wollender 9 months ago

  • Related to Bug #93085: Image Select and Image Cropping incorrect after TYPO3 update to v10.4.11 added
#2

Updated by Simon Gilli 9 months ago

  • Related to deleted (Bug #93085: Image Select and Image Cropping incorrect after TYPO3 update to v10.4.11)
#3

Updated by Česlav Przywara 9 months ago

I can confirm the problem is still present in TYPO3 10.4.12.

#5

Updated by Julian Hofmann 9 months ago

#92382 sounds similar but seems to be different. It describes a problem tested under TYPO3 10.4.8. The above problem has only been seen since 10.4.11 (i.e. it still worked under 10.4.8).

#6

Updated by Marc Willmann 8 months ago

Same problem here. Works fine until 10.4.10, breaks with 10.4.11 (and isn't fixed in 10.4.12)

#7

Updated by Česlav Przywara 8 months ago

  • Has duplicate Bug #93238: Regression: After deleting image in record "add" button is not displayed again added
#8

Updated by Julian Hofmann 8 months ago

It seems, it was introduced with #91595.
(from duplicate #93238)

#9

Updated by Kevin Appelt 8 months ago

  • Priority changed from Should have to Must have

The problem also exists in v11 (in 11.0.0 and dev-master)

#10

Updated by Webadmin no-lastname-given 8 months ago

  • Is Regression set to Yes

Can confirm it in relation with "maxitems = 1". It worked definitely fine in 10.4.10

#11

Updated by Gerrit Code Review 8 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67541

#12

Updated by Gerrit Code Review 8 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67541

#13

Updated by Gerrit Code Review 8 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67541

#14

Updated by Gerrit Code Review 8 months ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67542

#15

Updated by Gerrit Code Review 8 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67541

#16

Updated by Benni Mack 8 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#17

Updated by Andreas Fernandez 7 months ago

  • Has duplicate Bug #93479: TCA inline file with maxitems to 1, can't add after delete added
#18

Updated by Frans Saris 7 months ago

  • Related to Bug #91808: Nested IRRE with maxitems hides last inline control button / toggles inline control buttons wrong added
#19

Updated by Benni Mack 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF