Project

General

Profile

Actions

Bug #93423

closed

wrong https in slug of one page

Added by Franz Holzinger over 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
Start date:
2021-02-03
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.3
Tags:
Complexity:
nightmare
Is Regression:
Sprint Focus:
On Location Sprint

Description

The website example.com runs as http . The slugs of all pages show the correct http://example.com at the beginning text output. However one page shows a wrong protocoll https.
This error can also be seen in the frontend. Only one page has a link into https, the others to the http protocol.

page.10.marks.MAINNAV = HMENU
page.10.marks.MAINNAV {
special = list
special.value = 10,11,22
excludeUidList =
1 = TMENU
1 {
#noBlur = 1
wrap = <ul> | </ul>
NO = 1
NO.ATagTitle.field = description // title
NO.allWrap = <li> | </li>
NO.ATagBeforeWrap = 1
NO.stdWrap.htmlSpecialChars = 1
}
}

config.yaml:

base: 'http://example.com/'
rootPageId: 2
websiteTitle: 'Demo Example'

I find no possibility to change the slug of the page "Home id=10" from https into http.

The TYPO3 page tree is like this:

Demo id=2
several Sysfolders ....
Home id=10
Dienste id=11

Files

pages-https-10.csv (1.96 KB) pages-https-10.csv Franz Holzinger, 2021-02-04 18:18

Related issues 2 (2 open0 closed)

Related to TYPO3 Core - Bug #90436: Some weird behaviour with autogenerated site configNew2020-02-19

Actions
Related to TYPO3 Core - Bug #90163: Site config still being used even if page is no longer site rootNew2020-01-21

Actions
Actions #2

Updated by Georg Ringer over 3 years ago

  • Status changed from New to Needs Feedback

thanks for creating this issue!

this looks like https://docs.typo3.org/c/typo3/cms-core/master/en-us/Changelog/8.6/Breaking-79302-MovedPagesurlSchemeToCompatibility7Extension.html?highlight=protocol but this is gone since 8.6 or https://docs.typo3.org/c/typo3/cms-core/master/en-us/Changelog/9.0/Breaking-71306-DroppedProtocolFieldFromPageTypeLinkToExternalURL.html?highlight=protocol

I don't have any clue how this is possible, so can you compare this page with another one in e.g. phpmyadmin to find a difference?

Actions #3

Updated by Franz Holzinger over 3 years ago

All the pages work fine with http under slug, only page 10 (renamed into Falsch) provides only https.

No field url_scheme is available for pages. No compatibility7 has been installed or activated.
For finding of this error, all local extensions have been deactivated.

The difference between the old wrong "home" page (now called "falsch" and the newly entered "home" page (on the same positiion in the page tree where the other page has been before).

uid title    crdate         keywords    description   abstract   tsconfig_includes  rowDescription slug

10  Falsch   1389728335     NULL         NULL         NULL     NULL               NULL            /falsch

35  Home     1612454062                                                                               /home

I have compared it with another page.
The only difference are these three columns:

keywords description abstract

Actions #4

Updated by Georg Ringer over 3 years ago

sorry absolutly got no clue what could be wrong here and also never saw this issue in any of my projects. you would need to debug the link building

Actions #5

Updated by Franz Holzinger over 3 years ago

  • Complexity set to nightmare

I have found out now the reason for this error.
There has been a backup copy file typo3conf/sites/demoshop-orig and the old version of the config.yaml there. The real config file config.yaml under typo3conf/sites/demoshop has been activated in the TYPO3 backend.
However TYPO3 did also process the other old copy config.yaml. On the old config the page with id=10 has been set as the

base: 'https://mywebsite.com/'
rootPageId: 10

Both identifiers have been used by TYPO3. Only the first should have been used however. TYPO3 did not tell me that it also wanted to use this old backup copy.
It still did not work after the deletion of the backup folder. Also the TYPO3 cache had to be cleared.
After this also the page 10 did show the http in the backend at the slug field.

Actions #6

Updated by Riccardo De Contardi over 3 years ago

These issues look somehow related?

#90163

#90436

Actions #7

Updated by Franz Holzinger over 3 years ago

Yes, this issue is very similar to Bug #90436. The only addition is that even http can be changed into https for only one page if a second, but not assigned site configuration is included, but this should not have happend.

Actions #8

Updated by Franz Holzinger over 3 years ago

  • Related to Bug #90436: Some weird behaviour with autogenerated site config added
Actions #9

Updated by Riccardo De Contardi about 3 years ago

  • Category set to Link Handling, Site Handling & Routing
Actions #10

Updated by Benni Mack over 2 years ago

Franz Holzinger wrote in #note-7:

Yes, this issue is very similar to Bug #90436. The only addition is that even http can be changed into https for only one page if a second, but not assigned site configuration is included, but this should not have happend.

Are you using config.baseUrl ?

Actions #11

Updated by Franz Holzinger over 2 years ago

No "config.baseUrl" setup is used.

Actions #12

Updated by Benni Mack over 2 years ago

  • Status changed from Needs Feedback to Accepted

Franz Holzinger wrote in #note-11:

No "config.baseUrl" setup is used.

OK. After re-reading I think we should throw a big warning if there are two configurations with the same "rootPageId".

Actions #13

Updated by Oliver Hader over 1 year ago

  • Sprint Focus set to On Location Sprint
Actions #14

Updated by Benni Mack over 1 year ago

  • Related to Bug #90163: Site config still being used even if page is no longer site root added
Actions #15

Updated by Gerrit Code Review over 1 year ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/76516

Actions #16

Updated by Gerrit Code Review over 1 year ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/76516

Actions #17

Updated by Gerrit Code Review over 1 year ago

Patch set 3 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/76516

Actions #18

Updated by Susanne Moog over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #19

Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF