Bug #93938

Backend: menu_pages CE will throw an error when it contains references to deleted pages

Added by Florian Wessels about 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2021-04-16
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since version 10.4.15 the TYPO3 backend will throw an exception in the page module when the page contains a "menu_pages" content element that has a reference to a deleted page. This issue was introduced with commit 79e4001edf54f1996b33b5f02a5497f8edce9bc2. Other TYPO3 versions may be affected as well.

How to reproduce:

1) Create a menu_pages content element
2) Select pages
3) Save element
4) Delete one of the previously linked pages
5) Open the page containing the menu_pages element

See attached screenshot for any further details.


Files


Related issues

Related to TYPO3 Core - Bug #93659: No content element preview for menu typesClosedOliver Bartsch2021-03-05

Actions

Also available in: Atom PDF