Bug #94596

How to deactivate "simulate time" in adminpanel? Status of simulations not clear enough

Added by Sybille Peters 12 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
AdminPanel
Target version:
-
Start date:
2021-07-20
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
usability, adminpanel, simulate time, simulate group
Complexity:
Is Regression:
Sprint Focus:

Description

Currently, I have a problem because I am not sure if my simulate time settings are active and how to deactivate them.

With "Usergroup" I can explicitly select a blank option in the list and thus deactivate it. With "simulate time" there is no such option and I am unsure how to deactivate it.

In addition to this, no matter what I select for the date, the date looks greyed out.

Also, when I select a usergroup, there used to be GET-Parameters in the URL. This is no longer the case and I am unsure if this is actually working. I can test it, but I am currently trying to figure out something else and all this is making it really difficult.

This may be browser thing because the browser may display the form fields differently, but IMHO this should be well usable in any browser and there should be a clear indication if the simulation is on - maybe even with an additional warning on top if any simulation is activated .

I already had several problems with this with people reporting bugs and overlooking that they had activated the usergroup simulation or myself trying to find out how cache flushing works in combination with the adminpanel etc.

Apart from some things actually being buggy or being not sure if they are working correctly, see #91225.

Versions

  • TYPO3 10.4.17

Screenshots

With chromium browser, after selecting a date:

(date looks greyed out to me, time does not)


Files

simulate_time.png (4.49 KB) simulate_time.png Sybille Peters, 2021-07-20 09:17

Related issues

Related to TYPO3 Core - Bug #91225: TYPO3 v9.1.15 Admin-Panel, Simulate FE-Time not workingResolved2020-04-28

Actions
#1

Updated by Sybille Peters 12 months ago

  • Related to Bug #91225: TYPO3 v9.1.15 Admin-Panel, Simulate FE-Time not working added
#2

Updated by Sybille Peters 12 months ago

  • Description updated (diff)
#3

Updated by Sybille Peters 12 months ago

  • Description updated (diff)
#4

Updated by Sybille Peters 12 months ago

  • Description updated (diff)
#5

Updated by Sybille Peters 12 months ago

  • Description updated (diff)
#6

Updated by Gerrit Code Review 6 months ago

  • Status changed from New to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/72826

#7

Updated by Gerrit Code Review 6 months ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/72826

#8

Updated by Gerrit Code Review 6 months ago

Patch set 1 for branch 11.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/72883

#9

Updated by Susanne Moog 6 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF