Bug #91225

TYPO3 v9.1.15 Admin-Panel, Simulate FE-Time not working

Added by Gabriel Kaufmann / Typoworx NewMedia 7 months ago. Updated 4 months ago.

Status:
New
Priority:
Should have
Assignee:
-
Category:
AdminPanel
Start date:
2020-04-28
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
TYPO3-9.1.15 Simulate Time
Complexity:
Is Regression:
Sprint Focus:

Description

The Admin-Panel function Simulate FE-Time is not working at all in TYPO3 version 9.1.15! Submitting the Admin-Panel form with changed "simulate date/time" will change the given date/time after submiting. The frontend doesn't actually seem to get the desired time, so records with start/stop time do not behave as expected!

After a long journey to find any configuration error in TYPO3 or PHP-Environment a downgrade to TYPO3 v9.1.14 worked to fix the issue. This indeed implies there must be any bug in TYPO3 Admin-Panel for v9.1.15 core.


Related issues

Related to TYPO3 Core - Bug #91083: Preview setting "showHiddenRecords" in the admin panel does not work.ClosedChristian Eßl2020-04-17

Actions
#1

Updated by Thomas Hempel 7 months ago

I confirm, that this is still (or again) an issue in version 9.5.17

#2

Updated by Björn Prothmann 6 months ago

Same in 9.5.18

#3

Updated by DANIEL Rémy 6 months ago

I found that the PreviewSimulator middleware clear the DateTimeContext set by the admin panel's PreviewModule middleware.

Disabling the PreviewSimulator middleware fix the issue for my use case.

#4

Updated by DANIEL Rémy 6 months ago

  • Related to Bug #91083: Preview setting "showHiddenRecords" in the admin panel does not work. added
#5

Updated by Sascha Löffler 5 months ago

I can confirm it for TYPO3 v9.5.19.

This patch solves the display of the timed content elements
https://review.typo3.org/c/Packages/TYPO3.CMS/+/64491

but it does still not show the "Preview" box on the site (which i suspect is the expected behavior if i look at the code.)

So i had not only to delete the `$GLOBALS['TSFE']->clear_preview();` call, but also add

if ($queryTime === false && $GLOBALS['SIM_ACCESS_TIME'] !== $GLOBALS['ACCESS_TIME']) {
    $queryTime = $GLOBALS['SIM_ACCESS_TIME'];
}

to the `simulateDate` method because ADMCMD_simTime is not filled when setting the simulation time using the admin panel.

see:
https://github.com/lsascha/TYPO3.CMS/commit/59c23fd2d43e2676e8fa8eb69f40ef9a69f399c8

#6

Updated by Stefan Berger 4 months ago

we could confirm the bug and the proposed bugfix

Also available in: Atom PDF