Bug #94808

Clear Cache when creating new redirect after slug change

Added by Tim Schreiner 9 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Caching
Target version:
-
Start date:
2021-08-11
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When a new redirect records is created by updating a page slug, the redirect cache does not get cleared.
This results in a non working redirect until page cache is cleared.

This is because the Cache clear/rebuild is done by a DataHandler Hook but the redirect gets inserted by QueryBuilder.


Related issues

Is duplicate of TYPO3 Core - Bug #93964: Edit page, modify page slug causes HTTP 404 on old page URL. TYPO3\CMS\Redirects\Service\SlugService::rebuildSlugsForSlugChange must force-rebuild redirects cache. Closed2021-04-21

Actions
#1

Updated by Gerrit Code Review 9 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/70461

#2

Updated by Gerrit Code Review 7 months ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/71359

#3

Updated by Georg Ringer 7 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#4

Updated by Helmut Hummel 4 months ago

  • Is duplicate of Bug #93964: Edit page, modify page slug causes HTTP 404 on old page URL. TYPO3\CMS\Redirects\Service\SlugService::rebuildSlugsForSlugChange must force-rebuild redirects cache. added

Also available in: Atom PDF