Bug #95123

Automatically added Redirects do not spawn a Notification any more

Added by Jonas Eberle about 1 month ago. Updated 12 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2021-09-06
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
medium
Is Regression:
Yes
Sprint Focus:

Description

There have been notifications when redirects where added for https://docs.typo3.org/c/typo3/cms-core/master/en-us/Changelog/10.1/Feature-89115-Auto-createRedirectsOnSlugChanges.html until commit bd0b2929027ed053c77f288a40c9e4f228cb37c7


Files

clipboard-202109061657-mu4ql.png (14.3 KB) clipboard-202109061657-mu4ql.png Jonas Eberle, 2021-09-06 14:57

Related issues

Related to TYPO3 Core - Task #94114: EditDocumentController should use a POST request for persisting to DataHandlerClosedBenni Mack2021-05-11

Actions
Related to TYPO3 Core - Feature #89115: Auto-create Redirects on Slug ChangesClosedFrank Naegler2019-09-09

Actions
#1

Updated by Jonas Eberle about 1 month ago

  • Related to Task #94114: EditDocumentController should use a POST request for persisting to DataHandler added
#2

Updated by Oliver Hader about 1 month ago

  • Status changed from New to Accepted

Confirmed & caused by https://review.typo3.org/c/Packages/TYPO3.CMS/+/68714/9/typo3/sysext/backend/Classes/Controller/EditDocumentController.php#416

Previously the response did contain HTML and corresponding markup to trigger notifications.
With having an HTTP GET redirect in place, this does not work anymore and needs a different concept/approach.

Notifications are triggered by \TYPO3\CMS\Redirects\Service\SlugService::sendNotification using

        GeneralUtility::makeInstance(PageRenderer::class)->loadRequireJsModule(
            'TYPO3/CMS/Backend/BroadcastService',
            sprintf('function(service) { service.post(%s); }', json_encode($data))
        );

#3

Updated by Oliver Hader about 1 month ago

  • Target version set to 11 LTS
#4

Updated by Oliver Hader about 1 month ago

  • Related to Feature #89115: Auto-create Redirects on Slug Changes added
#5

Updated by Oliver Hader about 1 month ago

  • Complexity set to medium
#6

Updated by Gerrit Code Review 17 days ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/71410

#7

Updated by Gerrit Code Review 17 days ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/71410

#8

Updated by Gerrit Code Review 17 days ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/71410

#9

Updated by Benjamin Franzke 17 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#10

Updated by Benni Mack 12 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF