Bug #95478

I can't install TYPO3 11.5 via Composer on DDEV 1.18.0

Added by Stefan Froemken 2 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
composer
Target version:
Start date:
2021-10-05
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hello Core-Team,

thank you for releasing the new TYPO3 11.5 version today.

I have installed TYPO3 that way:

ddev config --composer-version 2 --create-docroot --docroot public --mutagen-enabled --php-version 7.4 --project-name typo3115 --project-type typo3 --timezone Europe/Berlin

Install base-distribution like explained here:
https://docs.typo3.org/m/typo3/guide-installation/10.4/en-us/QuickInstall/Composer/Index.html

ddev composer create "typo3/cms-base-distribution:^11" --prefer-dist

Activate Setup Wizard

touch public/FIRST_INSTALL

At the last step of the Wizard (username, email, sitename) the button to create the DB tables returns an error 500 in Dev-Console of the Browser:

Tue, 05 Oct 2021 15:41:35 +0200 [CRITICAL] request="3070caef61d80" component="TYPO3.CMS.Core.Error.DebugExceptionHandler": Core: Exception handler (WEB: BE): Symfony\Component\DependencyInjection\Exception\RuntimeException, code #0, file /var/www/html/vendor/symfony/dependency-injection/Compiler/DefinitionErrorExceptionPass.php, line 54: Cannot autowire service "TYPO3\CMS\Core\DataHandling\SoftReference\SoftReferenceParserFactory": argument "$runtimeCache" of method "__construct()" references interface "TYPO3\CMS\Core\Cache\Frontend\FrontendInterface" but no such service exists. You should maybe alias this interface to one of these existing services: ...

It seems that EXT:frontend was not loaded at that point. After

ddev composer dumpautoload

the DB tables are created successfully.

Nice greetings

Stefan


Related issues

Related to TYPO3 Core - Bug #95477: Package sorting wrong on first composer installClosed2021-10-05

Actions
#1

Updated by Stefan Froemken 2 months ago

Wolfgang Wagner just told me that he has the same problem. He has solved it with:

vendor/bin/typo3cms install:setup
#2

Updated by Gerrit Code Review 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/71443

#3

Updated by Nikita Hovratov 2 months ago

  • Related to Bug #95477: Package sorting wrong on first composer install added
#4

Updated by Nikita Hovratov 2 months ago

It's fixed on the surface with #95477, but should be further addressed.

#5

Updated by Gerrit Code Review 2 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/71443

#6

Updated by Nikita Hovratov 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#7

Updated by Simon Schaufelberger 2 months ago

I had this issue as well, even without ddev. Just a simple upgrade from 11.4 to 11.5 and then run the new clear cache command and then it crashed.

#8

Updated by Benni Mack 2 months ago

  • Status changed from Resolved to Closed
#9

Updated by Lina Wolf 2 months ago

I also have this issue on the test server but not on ddev. Still using ddev 1.17

#10

Updated by Daniel Haupt 2 months ago

Lina Wolf wrote in #note-9:

I also have this issue on the test server but not on ddev. Still using ddev 1.17

Try running composer install again. The issue is already resolved on master.

We experience this issue as part of our CI pipeline (while running our acceptance tests). For the moment, we fixed it by running composer install twice.

Also available in: Atom PDF