Project

General

Profile

Actions

Bug #97440

open

Search in selectMultipleSideBySide not working in Safari

Added by Mathias Bolt Lesniak over 2 years ago. Updated about 2 months ago.

Status:
Accepted
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2022-04-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:
On Location Sprint

Description

When entering a search term into the right box of a selectMultipleSideBySide field, nothing happens if you are using Safari.

The search works as expected in Firefox and Chrome.

This issue only occurs in TYPO3 v11.


Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #95458: Search in TCA renderType selectMultipleSideBySide not working in SafariClosed2021-10-04

Actions
Actions #1

Updated by Oliver Bartsch over 2 years ago

  • Status changed from New to Accepted

Can confirm (also in main). It seems like Safari does not allow to "hide" options. Since #91911, the options are no longer removed from the select but just the hidden attribute is set. Unfortunately, due to further changes, e.g. #95137, which rely on the changes from #91911, it's not that easy to roll back to the old "logic".

Actions #2

Updated by Michael Telgkamp about 2 years ago

  • Is duplicate of Bug #95458: Search in TCA renderType selectMultipleSideBySide not working in Safari added
Actions #3

Updated by Benni Mack 12 months ago

  • Sprint Focus set to On Location Sprint
Actions #4

Updated by Garvin Hicking about 2 months ago ยท Edited

  • Status changed from Accepted to Closed
Actions #5

Updated by Garvin Hicking about 2 months ago

  • Status changed from Closed to Accepted

Still reproducible in v13 main with Safari Version 17.5 (19618.2.12.11.6), probably because like Oliver mentioned Safari is lacking this filtering support

Actions

Also available in: Atom PDF