Project

General

Profile

Actions

Bug #98065

closed

TypoScript image file link with target _blank

Added by Benjamin Robinson over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Start date:
2022-08-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

I have a simple image gallery where some images are linked to PDFs, which should open in a new window:

tt_content.imagegallery = FILES
tt_content.imagegallery{
references.fieldName = image
renderObj = COA
renderObj {
stdWrap.typolink.parameter.data = file:current:link
10 = IMAGE
10.file.import.data = file:current:publicUrl
}
}

The links stored in the backend look like this `t3://file?uid=1822 _blank`

I get the following error:

The UID of file has to be numeric. UID given: "1822 _blank"

If I set a static link-parameter via TypoScript …

stdWrap.typolink.parameter = t3://file?uid=1822 _blank

… there is curiously no error.

The issue occurred with Typo3 version 11.5.11. and the cause is likely to be [bugfix e16fd7cba6][1].


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #80896: TypolinkViewhelper with linkhandler ignores class attributeClosed2017-04-19

Actions
Related to TYPO3 Core - Bug #97869: typolink with returnLast returns also more information than just the URLClosedBenni Mack2022-07-07

Actions
Actions #1

Updated by Oliver Hader over 1 year ago

  • Related to Bug #80896: TypolinkViewhelper with linkhandler ignores class attribute added
Actions #2

Updated by Oliver Hader over 1 year ago

Probably a regression introduced with https://review.typo3.org/c/Packages/TYPO3.CMS/+/74620

Actions #4

Updated by Benjamin Robinson over 1 year ago

Felix, if I understand you correctly, the issue might have already been fixed with #97869? It is being released with version 11.5.14, isn't it? I would like to test it, but I can't find a LinkFactory.php file under typo3_src-11.5.13/typo3/sysext/frontend/Classes/Typolink/ (there is e.g. a LinkResultFactory.php). Was the file newly added?

Actions #5

Updated by Benjamin Robinson over 1 year ago

I could not find the Patch in 11.5.14, which was released today. I don't really understand the repository yet, but suspect it's because the patch was only pasted for the branch main, but not for branches 10.4 and 11.5.

Actions #6

Updated by Oliver Hader over 1 year ago

  • Related to Bug #97869: typolink with returnLast returns also more information than just the URL added
Actions #7

Updated by Oliver Hader over 1 year ago

Corresponding change in the Gerrit (in the mono-repository):
https://review.typo3.org/c/Packages/TYPO3.CMS/+/75046

→ obviously it has not been back-ported yet to TYPO3 v11

Actions #8

Updated by Oliver Hader over 1 year ago

  • Status changed from New to Resolved

Patch for TYPO3 v11 (to be released in v11.5.15) was merged.
Please create a new issue in case you still experience problems. Thx!

Actions #9

Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF