Project

General

Profile

Actions

Bug #98565

closed

Page type shortcut does not respect translated shortcut target

Added by Marc W almost 2 years ago. Updated 13 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2022-10-10
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
8.1
Tags:
Complexity:
Is Regression:
Sprint Focus:
On Location Sprint

Description

Translated versions of pages type shortcut always redirect to the shortcut target defined in default language.

How to reproduce:
Create the following page structure in TYPO3 11

- Home (type shortcut, shortcut target default language = Subpage1, german translation with shortcut target = Subpage2)
- Subpage1 (default language and german translation)
- Subpage2 (default language and german translation)

Expected behavior:
When visiting Home in default language you get redirected to Subpage1 and visiting home in german language you get redirected to Subpage2.

Acutal behavior:
You get redirected tp Subpage1 regardless of the language you select when visiting Home.

Comments:
- The expected behavior is what happend in TYPO3 10


Files


Related issues 3 (1 open2 closed)

Related to TYPO3 Core - Bug #98566: Wrong link to Shortcut Page targetClosed2022-10-10

Actions
Related to TYPO3 Core - Bug #99518: Custom page shortcut target for translated page causes errorsNew2023-01-11

Actions
Related to TYPO3 Core - Bug #87815: Page shortcut not working for translated pagesClosed2019-02-28

Actions
Actions #1

Updated by Marc W almost 2 years ago

In order to translate the shortcut target you have to select "Custom value" for field "Translation behavior".

Actions #2

Updated by Johann Bunkowski almost 2 years ago

Marc W wrote in #note-1:

In order to translate the shortcut target you have to select "Custom value" for field "Translation behavior".

I've experienced the same Problem. In my case every value was set "custom" in any language. I tripple checked.

I've spend a few hours debugging and came up with a quick solution. So I XClassed it for everyone (see lines 30 - 46):
https://github.com/jBunko/t311_shortcut_quickfixclass

Hope this helps.

EDIT: Caution, my solution fixes the Problem but induces a Bug for page links with different lang ID. (Nevermind that, this issue I hade was depending on something else)

This is actually a really tough bug, and I believe it's not recreatable on every system, since my first working fix was just a rendundance .

EDIT 2: XClass fetches the overlay via Connection Pool now. If you really want to ensure the correct overlay to load, use the current one.

Actions #3

Updated by Johann Bunkowski almost 2 years ago

  • Related to Bug #98566: Wrong link to Shortcut Page target added
Actions #4

Updated by Rene Tobias over 1 year ago

We have the same problem

Actions #5

Updated by Oliver Hader over 1 year ago

  • Sprint Focus set to On Location Sprint
Actions #6

Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/76459

Actions #7

Updated by Ina Beckmann over 1 year ago

  • Related to Bug #99518: Custom page shortcut target for translated page causes errors added
Actions #8

Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/76459

Actions #9

Updated by Gerrit Code Review about 1 year ago

Patch set 3 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/76459

Actions #10

Updated by Gerrit Code Review about 1 year ago

Patch set 4 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/76459

Actions #11

Updated by Gerrit Code Review about 1 year ago

Patch set 5 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/76459

Actions #12

Updated by Gerrit Code Review about 1 year ago

Patch set 1 for branch 12.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/79751

Actions #13

Updated by Benni Mack about 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #14

Updated by Benni Mack about 1 year ago

  • Related to Bug #87815: Page shortcut not working for translated pages added
Actions #15

Updated by Tim Spiekerkötter 6 months ago

Hi, are there any plans to fix this in TYPO3 11 as well? We found the solution for 12 but the problem still exists in 11.
Thanks

Actions #16

Updated by Tim Spiekerkötter 6 months ago

We also just recreated this on demo.typo3.org

There is a FAQ shortcut in the footer. We changed the target for the german translation and it does not seem to work. The link still links to /de/faq/ I would expect it to link to /de/fun-facts/.

See screenshot attached.

Actions #17

Updated by Benni Mack 13 days ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF