Project

General

Profile

Actions

Bug #11806

closed

Extension key handling requires SOAP extension

Added by Steffen Gebert almost 12 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Category:
Extension Manager
Target version:
Start date:
2010-12-31
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

Don't know, if this can be changed or makes sense, but I noticed that extension key handling requires the PHP SOAP extension.

Maybe it can be degrade more graceful or just output an error, instead of an ExtDirect Exception with stack trace (and password..).


Files

Actions #1

Updated by Steffen Kamper almost 12 years ago

  • Status changed from New to Accepted
  • Assignee set to Steffen Kamper
  • Target version set to 4.5 beta4

i will add a check for reports module (there are already 3 integrated)

Actions #2

Updated by Steffen Kamper over 11 years ago

  • Target version changed from 4.5 beta4 to 4.5 final
Actions #3

Updated by Steffen Kamper over 11 years ago

  • Target version changed from 4.5 final to 4.5.1
Actions #4

Updated by Susanne Moog about 11 years ago

  • Project changed from 1099 to TYPO3 Core
  • Target version deleted (4.5.1)
Actions #5

Updated by Helmut Hummel about 11 years ago

  • TYPO3 Version set to 4.5
  • Complexity set to easy
Actions #6

Updated by Mr. Jenkins almost 11 years ago

  • Status changed from Accepted to Under Review

Patch set 1 of change Ifad1a7e81fbec4a22707a7a12090234dbb7b9496 has been pushed to the review server.
It is available at http://review.typo3.org/6991

Actions #7

Updated by Gerrit Code Review almost 11 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/6991

Actions #8

Updated by Gerrit Code Review almost 11 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/6991

Actions #9

Updated by Gerrit Code Review almost 11 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/7333

Actions #10

Updated by Steffen Gebert almost 11 years ago

  • Assignee changed from Steffen Kamper to Steffen Gebert
Actions #11

Updated by Steffen Gebert almost 11 years ago

  • Category set to Extension Manager
  • Target version set to 4.6.3

Although this error can also occur in 4.5, I would not add this check there, as soap is not a required PHP extension in this version (was added starting with 4.6).

Extension key handling is an edge-case, I guess many developers use 4.5 to do this. Instead, adding a new requirement (at least that's how it looks like) in a patch-level release would IMHO cause more confusion. Feel free to comment, if you have a different opinion!

Actions #12

Updated by Mario Rimann almost 11 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #13

Updated by Xavier Perseguers over 10 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF