Bug #17284

no content in workspace preview when using select.selectFields

Added by gregory about 12 years ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2007-05-07
Due date:
% Done:

100%

TYPO3 Version:
4.1
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Looking for performance, i always restrict fields used in my select clause thanks to selectFields that way :

select.selectFields = header,bodytext // example which only fetch bodytext and header fields

The problem with this method is that my CONTENT won't retrieve any content in case i'm not in LIVE workspace. In my opinion, this is not the intended behaviour, since the selectFields function should take into account workspaces.

(issue imported from #M5575)

17284.patch View (936 Bytes) Benni Mack, 2011-05-12 05:04


Related issues

Related to TYPO3 Core - Bug #29783: getQuery: fields explicilty added on select <table>.* : Error: ambigious parameter uid Closed 2011-10-11
Related to TYPO3 Core - Bug #34152: stdWrap function numRows() fails in 4.6 due to wrong SELECT clause Closed 2012-02-21
Precedes TYPO3 Core - Bug #30486: Typoscript select join broken Closed 2011-09-30

Associated revisions

Revision e13d917e (diff)
Added by Tolleiv Nietsch over 7 years ago

[BUGFIX] No content in workspace preview when using select.selectFields

The TypoScript property select.selectFields does not consider workspaces
in the frontend rendering process.

Resolves: #17284
Releases: 4.6, 4.5, 4.4
Change-Id: Id9d1e7dcf56b5aeeec3070ff11416e82ec1bb978
Reviewed-on: http://review.typo3.org/2089
Reviewed-by: Tolleiv Nietsch
Tested-by: Tolleiv Nietsch

Revision 3fdaf5be (diff)
Added by Tolleiv Nietsch about 7 years ago

[BUGFIX] No content in workspace preview when using select.selectFields

The TypoScript property select.selectFields does not consider workspaces
in the frontend rendering process.

Taking the results from #29783 into account.

Change-Id: I6b2b68ed03163e9e0d7dd281aafea8af67fec224
Resolves: #17284
Releases: 4.6, 4.5, 4.4
Reviewed-on: http://review.typo3.org/4950
Reviewed-by: Oliver Hader
Reviewed-by: Wouter Wolters
Reviewed-by: Stefan Neufeind
Reviewed-by: Susanne Moog
Tested-by: Susanne Moog
Reviewed-by: Steffen Ritter
Tested-by: Steffen Ritter

History

#1 Updated by Benni Mack about 8 years ago

  • File 17284.patch View added
  • Category deleted (Miscellaneous)
  • Status changed from Accepted to Under Review
  • Target version deleted (0)

Attached is a patch that fixes this issue.

#2 Updated by Benni Mack about 8 years ago

Now in gerrit avaiable under: http://review.typo3.org/2089

#3 Updated by Benni Mack about 8 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core

#4 Updated by Mr. Hudson about 8 years ago

Patch set 2 of change Id9d1e7dcf56b5aeeec3070ff11416e82ec1bb978 has been pushed to the review server.
It is available at http://review.typo3.org/2089

#5 Updated by Mr. Hudson almost 8 years ago

Patch set 3 of change Id9d1e7dcf56b5aeeec3070ff11416e82ec1bb978 has been pushed to the review server.
It is available at http://review.typo3.org/2089

#6 Updated by Mr. Hudson over 7 years ago

Patch set 4 of change Id9d1e7dcf56b5aeeec3070ff11416e82ec1bb978 has been pushed to the review server.
It is available at http://review.typo3.org/2089

#7 Updated by Mr. Hudson over 7 years ago

Patch set 1 of change I6b2b68ed03163e9e0d7dd281aafea8af67fec224 has been pushed to the review server.
It is available at http://review.typo3.org/4950

#8 Updated by Tolleiv Nietsch over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Gerrit Code Review over 7 years ago

  • Status changed from Resolved to Under Review

Patch set 3 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/4950

#10 Updated by Tolleiv Nietsch about 7 years ago

  • Status changed from Under Review to Resolved

#11 Updated by TO_Webmaster no-lastname-given about 7 years ago

This solution breaks aggregate functions. Especially, the TypoScript method numRows causes an SQL error:

Mixing of GROUP columns (MIN,MAX,COUNT,...) with no GROUP columns is illegal if there is no GROUP BY clause

#12 Updated by Marcus Krause about 7 years ago

... and this is the according ticket
#34152 (stdWrap function numRows() fails in 4.6 due to wrong SELECT clause)

#13 Updated by Benni Mack 8 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF