Project

General

Profile

Actions

Bug #18866

closed

Epic #68397: Make TYPO3 work with MySQL strict mode

Cannot create page with Mysl in strict mode (STRICT_TRANS_TABLES)

Added by Martin Kutschker about 16 years ago. Updated almost 9 years ago.

Status:
Rejected
Priority:
Should have
Category:
-
Target version:
-
Start date:
2008-05-28
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When I want to create a page I get an Mysql error saying that it has an inavlid value for an integer field. The problem is that "storage_pid" is when not set initially an empty string. It seems that I get only default values in strict mode for NULL, but no type conversion from empty string to 0 occurs.

A possible solution would be to use 0 as TCA default, but I think it is more proper to make the conversion in TCEmain if necessary.

(issue imported from #M8542)


Files

bug_8542.diff (1.24 KB) bug_8542.diff Administrator Admin, 2008-05-28 17:16

Related issues 5 (0 open5 closed)

Related to TYPO3 Core - Bug #52204: SQL error: Incorrect integer value: '' for column 'backend_layoutRejected2013-09-24

Actions
Related to TYPO3 Core - Bug #52206: Default-values for text-fieldsClosed2013-09-24

Actions
Related to TYPO3 Core - Bug #52596: Creating pages tries to assign empty string to integer fieldClosed2013-10-07

Actions
Related to TYPO3 Core - Task #54883: Document that TYPO3 CMS is not compatible with MySQL strict modesClosedErnesto Baschny2014-01-09

Actions
Is duplicate of TYPO3 Core - Bug #20052: SQL error: 'Incorrect integer value: '' for column 'storage_pid' at row 1' (pages:NEW499d21cdec168)Rejected2009-02-19

Actions
Actions #1

Updated by Johannes about 16 years ago

confirming this bug. seems to be related with 0004693

Actions #2

Updated by Martin Kutschker about 16 years ago

No, the definition of "storage_pid" has not been changed.

Actions #3

Updated by Johannes about 16 years ago

yes of course. my comment was missleading.I mean: both bug come from mysql-5 strictmode and could alternatively (at least for me) be solved by changing sql-mode to MYSQL40 in my.ini.

Actions #4

Updated by Rene van Asperen almost 16 years ago

The attached diff file seems to fix the problem. Can you give me some feedback about it?

Actions #5

Updated by Marcos Fadul over 15 years ago

The diff file fix the problem for me too.
Good work.

Actions #6

Updated by Gerrit Code Review about 11 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19671

Actions #7

Updated by Gerrit Code Review about 11 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19671

Actions #8

Updated by Gerrit Code Review about 11 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19671

Actions #9

Updated by Alexander Opitz about 11 years ago

  • Assignee set to Alexander Opitz
  • Target version deleted (0)
Actions #10

Updated by Gerrit Code Review about 11 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19671

Actions #11

Updated by Gerrit Code Review about 11 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19671

Actions #12

Updated by Gerrit Code Review almost 11 years ago

Patch set 6 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19671

Actions #13

Updated by Gerrit Code Review almost 11 years ago

Patch set 7 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19671

Actions #14

Updated by Gerrit Code Review almost 11 years ago

Patch set 8 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19671

Actions #15

Updated by Gerrit Code Review almost 11 years ago

Patch set 9 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19671

Actions #16

Updated by Gerrit Code Review almost 11 years ago

Patch set 10 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19671

Actions #17

Updated by Gerrit Code Review almost 11 years ago

Patch set 11 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19671

Actions #18

Updated by Gerrit Code Review almost 11 years ago

Patch set 12 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19671

Actions #19

Updated by Anonymous almost 11 years ago

  • Status changed from Under Review to Resolved
Actions #20

Updated by Gerrit Code Review almost 11 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/23237

Actions #21

Updated by Stefan Neufeind almost 11 years ago

Patch was reverted again since, after some discussion, this was not the right place to add the additional check. Will need a follow-up. The general idea itself however was okay.

Actions #22

Updated by Anonymous almost 11 years ago

  • Status changed from Under Review to Resolved
Actions #23

Updated by Chris topher almost 11 years ago

  • Status changed from Resolved to New
Actions #24

Updated by Mathias Schreiber over 9 years ago

  • Status changed from New to Rejected

Making TYPO3 work with script mode is at least a year of work.
We have this on our agenda, but since this touches a wider aspect of the code I'm closing these tickets down.

Actions #25

Updated by Morton Jonuschat almost 9 years ago

  • Parent task set to #68397
  • Is Regression set to No
Actions

Also available in: Atom PDF