Project

General

Profile

Actions

Bug #20378

closed

Problem with sorting categories

Added by Tobias Schweizer almost 15 years ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
2009-04-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

indexed_search (extended mode) always uses the category "date of last change" as a sorting criterion even though the user selects another category as a sorting criterion. When the user selects a category and submits his request, his selection of category does not remain active. Indexed_search switches back to the category "date of last change".

We use indexed_search version 2.11.1
(issue imported from #M11011)

Actions #1

Updated by Alexander Opitz almost 11 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • TYPO3 Version set to 4.3

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

Actions #2

Updated by Tizian Schmidlin almost 11 years ago

This is still an issue but since I think we figured out, why this happens: the sorting changes automatically to m_time in order to save performance when looking up multiple search words, thus the sorting category is reset.

It would be nice to have at least an option for indexed search in order to disable this specific behaviour, even though search then take longer to proceed.

Actions #3

Updated by Alexander Opitz almost 11 years ago

  • Status changed from Needs Feedback to New
Actions #4

Updated by Mathias Schreiber over 9 years ago

  • Target version set to 7.5
  • Is Regression set to No
Actions #5

Updated by Benni Mack over 8 years ago

  • Target version changed from 7.5 to 7 LTS
Actions #6

Updated by Mathias Schreiber over 8 years ago

  • Target version deleted (7 LTS)
Actions #7

Updated by Tizian Schmidlin over 8 years ago

I'd just like to say, that this is still an issue (but we have a workaround for it, so no biggy).

If there is anything to be done with the search and it is completely replaced by something else, IMHO you can close the issue.

Regards
Tizian

Actions #8

Updated by Tomas Norre Mikkelsen over 1 year ago

I know this issue is quite old, but probably still an issue, but should at least be confirmed if so or not.

Can someone please add the steps to reproduce, I don't read that from the comments, so far.

Actions #9

Updated by Tizian Schmidlin over 1 year ago

Hi Tomas,

this can be reproduced by switching to extended search on any TYPO3 installation with indexed search.

There you select "Sort by" and set it to anything other than last changed. Now the sorting is reset to last modified, simply ignoring the user's selection.

As far as I can remember, the solution was an XClass that handled this differently, but it did, indeed, kill the performance of the search.

I haven't checked the source code to see if this is still there, though, so maybe this is closed anyways.

Regards
Tizian

Actions #10

Updated by Tomas Norre Mikkelsen over 1 year ago

I now see what you mean. I overlooked that yesterday, but I cannot reproduce the problem any more.

Could someone else please confirm, so that we can have the issue closed if not present any more.

TYPO3 11.5.19
PHP 8.0.24

Actions #11

Updated by Christian Kuhn 8 months ago

  • Status changed from New to Closed

Hey. I take the freedom to close here for now.

Actions

Also available in: Atom PDF